AR150 keeps disconnecting

I have used the ar151 for 4 years now with no problems. Finally updated it to the newest version for both luci and the install. Before I did it I noticed it disconnecting but after the latest install it is worse.

It works fine when I am using my TCL Verizon phone I got 3 months ago and seldom if ever disconnect but the Verizon Samsung J3 and J7 are the ones that seem a problem. When they disconnect the ar151 shows still connected to the easytether but thats all it does. sit there. when it says connected it might for a bit and then disconnect but the easytether says it is still connected. What has changed. Any ideas what to look for? they all work fine direct to the computers usb so I know it works fine there and as I said the TCL 5004 works fine to.
TIA for any ideas. Steve Rice

Are you saying that it disconnect to phone tethering?

3.201 uses openwrt 1907 so the easytether driver is changed. Should this be the problem?

Not sure but I have taken one and have totally erased it and am going to drop back to a lower openwrt because so far nothing is working when it is a samsung phone and easytether. They both loaded fine and then except for my one TCL verizon phone all the others just refuse to use easytether. Not sure what to try if this doesn’t work. Also that new Luci upgrade that it requires separate was a headache when I set that up in the pass but finally got all that. I do see that the router won’t show me upgrade from the router. Just says no internet even when I use the wan port. Fall back I think as that is where I am headed.

Here is what I have done, I erased the router and installed the up to date packages listed below and now will see if it stays on line or I will lose it. Yes, internally the input of the router would stop talking to the router output. Still showed connection on my cell phone usb but would just stop. Let you know if reloading the info below resolves the problem. Thanks

Hostname GL-AR150
Model GL.iNet GL-AR150
Architecture Atheros AR9330 rev 1
Firmware Version OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.044.30835-34e0d65
Kernel Version 4.14.221
Local Time 2021-06-07 20:39:05
Uptime 0h 18m 33s
Load Average 1.12, 0.61, 0.50
Protocol: DHCP client
DNS 1:
Expires: 49710d 6h 11m 18s
Connected: 0h 16m 57s
Device: Ethernet Adapter: “tap-easytether”
MAC-Address: 02:00:54:74:68:72
Powered by LuCI openwrt-19.07 branch (git-21.044.30835-34e0d65) / OpenWrt 19.07.7 r11306-c4a6851c72

Ok,with above installed mentioned router I have found that the GL-AR150 is still having a problem with Verizon J3 and Verizon J7 cell phones. They will stop sending and receiving data with the router for no real reason. TCL cell has not had the disconnect the problem. Don’t know if there is something to the TCL having a USB -C plug for data versus the micro for the Verizon devices.

At this point I have no idea what could be doing it but if anyone else has a advice let me know. thanks

Did you use this package to install on the router?

Hi, yes I did. easytether-usb-openssl_0.8.9-5_mips_24kc.ipk and openwrt-ar150-3.201-0402.bin . It seems that the problem may be some other thing that is Verizon has done? They have never done something before. The ar150 feeds a Archer C7 router which feeds my house and has worked fine until this started happening. I have always been able to look at the ar150 from any of the computers and see it fine. Tried just a computer to a router and same problem so ruled out the Archer C7 connection.MOre testing today. Will change the IP of the AR150 to the standard default of to see if that has a problem but really shouldn’t. Hmmm

Ok, finally got to a closer area of the problem. It seems that now the Samsung J7 connected to the router and in turn going to the lan card on the computer seems to work fine. the same with the J5 to the AR150.

The problem is if you connect the AR150 to another router to feed more then one computer it will get erratic and disconnect and connect when it feels like it. I I am logged on the AR150 I can see it disconnect internet when viewing internet. unplug the router and plug the cell back it says has internet. Just don’t do anything much as it will disconnect again. I
If I have the TCL connected in the same format it works fine.
So, any idea why the Samsung’s have a issue with speed connectivity? I have tried lowering MTU for different stuff to no luck.
Don’t know what I could change in the J7 and J5 to see where it is coming from.
Anybody got ideas? Right now I am running J7 cell to one router to my main computer. The backup router to the rest from the TCL cell phone that doesn’t have problems.

Should I find a new GL-inet router that has 4 lan ports built in that will load with easytether? Seems they should all be the same pretty much I would think.


Ok, new question. My dish network is unable to connect to the internet from the router. Seems first there is only 1 dns and I see no way to add a second dns server in the ar150. Anyone no where to add a second DNS such as and where does it even show the DNS1 that it shows but do not actually see it where it could be changed. According to the dish it show connect from the router (the AR150) to the internet connection. Thanks

In more settings->custom dns server you can set 2 dns servers

Found it where you said it was. Thanks

Ok, after testing the easytether I find it works fine with all the cell phones I have as long as they are connected to any of our computers without the AR150 Routers. Something has changed as when the router is used it will disconnect when it wants to . It seems that there is something the verizons we use seem to recognize the router or some quirk in the new routers are causing it. Am going to try a different router with easytether installed in them to see if it is a specific router or all brands. Will update when I get a chance as it is a bit time consuming. I see no one else had any ideas so will keep it updated. Thanks