AR150 Wireless Bridge setup... This is way harder than it should be


#1

What an effort this has been and I’m not sure I’m home yet…
I want to use the AR150 as wireless bridge client (station) to extend my office lan to remote devices (same subnet). Fiddling about with the AR150/html interface yielded nothing positive. Moving into the advanced interface I somehow managed to screw it up to where I could no longer access it and the 10 second reset had no effect.
Ubooting brought me to the firmware update page and i loaded the openwrt-clean-gl-ar150-1.0.bin firmware (I have no idea if this is different from the openwrt-ar150-clean-2.264.bin firmware… same date, same size).
Now I no longer have the fancy AR150 GUI page but that’s ok…
I followed this guide and the desired functionality appears to be working as expected… so far it looks promising, but haven’t really fully tested yet.
https://openwrt.org/docs/guide-user/network/wifi/relay_configuration

I have 4 more AR150’s to configure like this, only difference being its IP address. Should I just uboot and update the firmware like i did this one? or is there something I should do different?


#2

Don’t know what you did exactly and I don’t have the AR150 but the MT300N-V2, but I can imagine that the interface looks similar.

So you are trying to use the AR150 as wifi repeater and connect your PC (or what ever) via LAN?
like this?:
Untitled%20Diagram%20(1)

It should be simple, Settings->the first most upper -> new connection -> repeater: Select your SSID, inset PW select mode WDS and then I’m not total sure, but I think inset the IP from your main router. I can test it on my router in a moment.

When using the repeater mode in WISP your AR150 is generating a new network, but in WDS it does not, and so you get the same network.


#3

Okay, it takes a bit longer, can’t connect with WIFI now xD
Give me half an hour or so.


#4

So it works ish.
I connected my MT300N-V2 with my main router with WDS, I used the IP of my main router aka 192.168.xxx.1.
I just have the problem that I can’t connect to my main router with my PC which is connected to the main router via LAN but I can connect to the main router with my laptop which uses lan from the MT300N-V2. Other problem is that I can’t connected to the mini router, I mean the web interface.


#5

https://www.tp-link.com/uk/faq-227.html
" Note:
1.LAN IP of extended router should be different but in the same subnet of the root router;
2.The DHCP Server on extended router should be disabled;
3.WDS bridging only requires the WDS setting on either the root router or the extended router.
4.Make certain whether your router supports WDS or not."

That’s what I thought, that I should not be the same IP as the main router, I tried it once, but then the mini router didn’t connect.
Gonna try it again :slight_smile:


#6

My main router does not support WDS “The FRITZ!Box does not support the WDS (Wireless Distribution System) procedure. The trade association Wi-Fi Alliance discontinued further development of WDS more than 10 years ago. The WDS specification was therefore never modified in order to take the latest wireless standards for security and speed such as WPA2 and WLAN 802.11n into account.
The obsolete and unsafe WEP encryption method was used to establish WDS connections; it no longer supported by new wireless devices.”

It seems like WDS might not be the right choose, sorry can’t help more.
I think the right choose for you would have bin a mesh router https://www.gl-inet.com/products/gl-b1300/ , if your main router supports it (mine does).


#7

Not really a repeater in the wifi sense. I don’t want it to act as an AP, just a station but your diagram is correct. You’re having the same difficulty I was.

I have done more testing…

Kill the AP then restore, the ar150 reconnects as expected. Will try killing the AP for longer periods (like an hour), should still reconnect when AP becomes available again.

Reboot PC (AR150 powered from PC USB). Wired ethernet was turned off after reboot. Maybe because PC boots faster than AR150. Solved by modifying PC /etc/network/interfaces to override the Network Manager.
That may too be the reason the wired ethernet dropped after a period of time… I’ll see if disabling the Network Manager fixed that as well.

I see no way to make this work “out of the box” without going through the steps outlined in the openwrt guide.
It is connected now wirelessly to a Ubiquiti AC Mesh AP without issue.
The next test is to place everything on a private network without a router or gateway (as it will be in the field). I don’t anticipate any issues as everything is already static.


#8

you really don’t want the ‘clean’ firmware. it is just stock openwrt. you want the gl-inet branded interface that is designed for the hardware… yes I wish they would name them something else as its really confusing.

http://download.gl-inet.com/firmware/ar150/v1/

this is the latest gl-inet release:
http://download.gl-inet.com.s3.amazonaws.com/firmware/ar150/v1/lede-ar150-2.27.bin


#9

Yep… confusing for sure. No reason though once this firmware is installed that I cannot do everything i did before through the advanced gui and not even touch the branded interface is there?


#10

well you have the original openwrt that was first compiled when that router was released years ago installed. it doesnt have the latest security patches. gl-inet does a pretty good job at releasing upgrades when security issues arise and the interface will tell you about the upgrade and makes it easy to do so.

i wouldn’t run that – but your call.


#11

Yep… confusing for sure. No reason though once this firmware is installed that I cannot do everything i did before through the advanced gui and not even touch the branded interface is there?

Based on the drawing above, you want each 150 set up as a WDS repeater.

You can set up a WDS without GL-Inet’s interface, but it is way easier with using the GL-Inet firmware.

If you want to avoid using the GL firmware, my advice is to create a test network: flash the GL firmware on one AR150 device, set it up as a repeater using the GL firmware, then study that AR150’s luci configuration as it is setup. Once you fully understand the luci config, you should be able to replicate it using no GL firmware.