I just updated the firmware to 2.26 and now I can’t install sqm or wshaper because of a kernel requirement.
<pre class="error"> * satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-wshaper:
* kernel (= 3.18.27-1-HASH) *
* opkg_install_cmd: Cannot install package luci-app-wshaper.
Anyone else got the same problem?
Should I got back to 2.25 to get sqm?
update: went back to the 2.25 nand fw and I still get the same kernel dependency error.
Can you do a revert to factory default and try again. I think the link to the repo maybe wrong because of update.
Can you check and post the content of /etc/opkg/distfeeds.conf
atm @2.25 nand
src/gz chaos_calmer_base http://www.gl-inet.com/openwrt/ar71xx/2.25/packages/base
src/gz chaos_calmer_luci http://www.gl-inet.com/openwrt/ar71xx/2.25/packages/luci
src/gz chaos_calmer_management http://www.gl-inet.com/openwrt/ar71xx/2.25/packages/management
src/gz chaos_calmer_packages http://www.gl-inet.com/openwrt/ar71xx/2.25/packages/packages
src/gz chaos_calmer_oldpackages http://www.gl-inet.com/openwrt/ar71xx/2.25/packages/oldpackages
src/gz chaos_calmer_routing http://www.gl-inet.com/openwrt/ar71xx/2.25/packages/routing
src/gz chaos_calmer_telephony http://www.gl-inet.com/openwrt/ar71xx/2.25/packages/telephony
I've scheduled a maintenance in a couple of hours. I better get this going before morning.
I’ll keep you posted.
I see. It is a bug of upgrading and keeping settings.
Please revert to factory default and reboot again or you can manually change the above file. Change ar71xx to ar71xx_nand
Updated back to 226 and changed the distfeed.conf sources. Updated the sources and sqm works perfectly again.
So the right way to update is:
- Backup your configs.
- Update FW without maintaining configuration.
- Load the configs.
Or is it recommended to do it manually. From what I can tell from the new populated files is that they have more params and that would be the way to go.
Thanks for the help and best wishes from Peru.
Thank you all for this topic!
I changed the urls with the help of
sed command, here is it, for the record:
sed -i -e 's/ar71xx/ar71xx_nand/' /etc/opkg/distfeeds.conf
But it didn't helped me about installing
root@GL-AR300M:~# opkg install kmod-bluetooth bluez-libs bluez-utils kmod-usb-core kmod-usb-uhci kmod-usb2 usbutils
Installing kmod-bluetooth (3.18.27-1) to root...
Package bluez-libs (5.30-1) installed in root is up to date.
Package bluez-utils (5.30-1) installed in root is up to date.
Package kmod-usb-core (3.18.27-1) installed in root is up to date.
Package kmod-usb-uhci (3.18.27-1) installed in root is up to date.
Package kmod-usb2 (3.18.27-1) installed in root is up to date.
Package usbutils (007-1) installed in root is up to date.
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-bluetooth:
* kernel (= 3.18.27-1-614a690edd3b9a652fa55d68faabbaf9) *
* opkg_install_cmd: Cannot install package kmod-bluetooth.
So it misses the kernel with hash
, as only
root@GL-AR300M:~# opkg list kernel
kernel - 3.18.27-1-74422c6556264a9f9977cf38765072a1
I didn't tried resetting factory settings.
Should I try the 2.25 version? I have an
ar300m NAND dual band model.
After checking version 2.25, it looks like it doesn’t have this kernel version mismatch dependency error.
bluetooth-kmod it has other problems, but it is an OpenWRT bug, not GLi.
FYI, firmware version 2.261 fixes these kernel dependency problems!
/etc/opkg/distfeeds.conf problem is gone too.
Thank you all!