AR300M all LEDs on - power LED blinking - cant access setup page


I’ve had one of these AR300M routers before, and it worked fine for me so I bought a second for another project, however I can’t get this one to do anything. The Power LED is blinking slowly (about once per second), while the configurable and wifi leds are solid. The documentation does not mention what blinking power LED means, it says only that it should be solid.

I suspected the firmware was bad so I flashed the latest firmware (openwrt-ar300m-3.201-0402.img) and was successfully able to flash, however it is still doing the same thing.

There is no Wifi network I can find, either listed or hidden (I tried manually typing in the SSID and password listed on bottom of router - no luck). Connecting via LAN cable (in both ports) also does not work. Letting windows acquire an IP address from the router’s DHCP server doesn’t work, and manually entering IP address 192.168.8.x I am unable to ping the device at

Any help would be greatly appreciated, I am out of ideas.

Maybe just a defective one.

I don’t know why it blink power LED.

I wonder if you get any information on that power led blinking. I have the same problem.