ar300M and openvpn help needed


I have my own ovpn server running on a VPS. I connect the router to the ovpn server and it is successful. The problem is the wifi clients connected to the router do not get any internet access once the VPN connection is established. I run curl on the router and check my ip and it shows that my vpn is working. But nothing on WIFI is getting anything on the internet. As soon as i turn openvpn off, then all wifi enabled devices can get on the internet.

Is there a firewall or bridge that I need to create so WIFI can access the VPN network created?


Any help appreiciated.

I have some more information. I am able to get the vpn working for wifi devices by doing the following:

Connect / Enable openvpn client

Go to advanced > Network > Interfaces

Here I see VPN_CLIENT is bound to the interface TAP0 which is not right, so i modify the interface and bind it to tun0.

This disconnects the VPN client. I click connect again, and all of a sudden, VPN is now working.

It appears there is a bug somewhere that is bringing up the interface on tap instead of tun ??

Ive found the bug.


My configuration file had:

dev tun

;dev tap


Some reason your scripts picked up the commented tap device and created the interface as a tap interface. Might want to ignore any comments :slight_smile:

Is this the support expected if i were to buy this product in bulk? Disappointing. Ill be having words with Andy.

Thanks for reporting this bug. Will fix.

If you want order support please contact your sales person, that will be better. The forum is target for free discussion.


Actually you posted all your three post in 16th and the last comment is it is solved so I didn’t reply.

I posted all on the 16th and found the bug. Would of thought youd reply to acknowledge the issue, but no problem! Thanks for your reply. Sorry if mine was a bit strong!