AR300M - Correct Uboot File?

Have a stuffed AR300m and trying to uboot back.

What is the correct file to uboot reload? There seems to be Ubis and NANDS and all sorts of version??

Have tried a few of them an still don’t have a working device :frowning:

Help please :slight_smile:

So you want the NAND img file from here:

Or did you bork uboot itself?


No uboot is fine but if I load that file from directory you’ve suggestedI get the following sequence on leds
Solid power flash green flash red
Solid power flash green flash green/red
( or similar).
Just keeps repeating.
Wired connection (linux mint) says Wired - cable unplugged.

Hard power reset ends up in same flashing sequence and no wired connection :frowning:
No visible WiFi

Have tried the 3.104 and if I try the 3.104 adguard image I get:

I do believe that before I tried to reflash the wifi SSID it came up with was GL-AR300M-XXX-NOR if that means anything.


Further update. It would appear that I needed the AR300M16 NOR image to at least get it up and running again.

So next question is:

  1. What is the advantage of running out of NAND?
  2. How do I get NAND image onto the box?
  3. How do I make it boot from NAND rather than NOR?


Ah, well looking at this thread it has been covered a bit:

If yours says AR300M16 on the label, then you have only NOR and not dual memory :frowning:

Ok bit of a zombie thread but it’s my zombie thread :grin:

It was definitely a dual memory model.

When I first fired this up it was running the Nor version of firmware (observed by the WIFI SSID having NOR in the name).

Everytime I loaded a NAND image it went through but either rebooted into NOR firmware or went into a boot loop.

I tried forcing it to NAND load but that basically bricked it.

I decided to start from scratch and reloaded uboot from github. When this was done I actually got the option to install either a NOR or NAND firmware. When I first got it it didn’t have that option.

Loaded both NOR and NAND images and now it boots fine into NAND firmware. :grin:

History of this unit is sketchy so not sure if it’s come out of the factory with wrong uboot and firmware or if the previous owner mucked around with it.

Best thing is it’s fixed and working fine!

Might help someone :wink:

1 Like