AR300M-ext freezing with Wow-fi

Hello ,
Maybe someone can help me.
I just bought an AR300M-EXT and I’m using it as a repeater. I downloaded the last firmware and installed LUCI.
The device works very well with my wi-fi but, when I try to connect to Wow-fi it shows a strange behaviour.
When I’m home it connects and repeats flawlessly. In another place where I need it more (but also where signal is weaker) it tries to connect, then abruptly the AR300M stops responding, the Wi-Fi disappears and I need to reset it (4 seconds push on reset button) and wait a couple of minutes just to reconnect to the AR300.
The Wow-fi uses a WPA2 - EAP authentication.
Maybe the problem is that there are a couple of Wow-fi signals (all weak) and I don’t know how to link to a specific BSSID (I just disabled the auto reconnect for the repeater, but it keeps freezing the router anyway).
Perhaps in LUCI there is a way to do this but I need some help.
When I connect with my tablet to the Wow-Fi, there is no problem (same credentials, of course), both at home and in the other place.
I already tried reinstalling both firmware and LUCI, deleting and reassociating with Wow-Fi, but with no success. I tried long reset (deleting settings), still nothing.
The strange thing is that it freezes, not just disconnects from the Wow-fi
It seems that AR300 is going mad in dealing with more than one signal with same name, or that a weak signal is something weird for it…
If someone has any idea to solve the problem, I’ll be really grateful.
Thanks in advance

Did you see the router reboot?

Maybe you can do this, first, make sure you have a good power adapter. Use good 5V2A adapter and short power cable.

Second, if you have a cable connect to the LAN, when this happens, ssh to the router and get the log, using command logread and dmesg

Thank you,
the adapter is 1,5 A but I’ll try with another more powerful.
I’ll also try to connect it to my laptop with a LAN cable and get the log to analyze.
I cannot say it reboots: the router shuts down the wi-fi. I tried waiting and sometimes, after two or three minutes, it has the wi-fi back but seems very slow in responding and keeps shutting down the wi-fi.
Led are not so helpful (only the red one blinking for some seconds, then steady for some seconds and then blinkink again. The 2 green steady until I proceed resetting manually)

Seems it has trouble connect to wow-fi and keep trying. When it does this its own wifi signal will be affected so you cannot connect to it via wifi.

I’ll also try with a powerbank (5V2.1A) to see if outside, in different locations with different Wow-fi (different BSSID), it does the same thing, because somewhere (at home for example) it connects and repeats the signal with no problem at all.
You think it saves log also if it freezes? or do I need to go around with the laptop and lan cable and constantly refresh?

If just the wifi freezes, you should still be able to connect lan cable and connect to the router and get log.

Try this fix: