AR300m ext repeater mode issues (Captive portal)

Hi there,

I use this router mostly to connect to hotspots that have captive portal, this used to work last year on my travels to Europe with WISP but this year it doesn’t work anymore with the latest new firmware.

Note: I don’t have any issues repeating a wifi that has a login/password, just those that require a login page after connecting (like hotels, coffee shops, etc)

If I connect to the Hotspot using my MacBook or iPad I do get the captive portal login page, but not when with the router with repeater mode.

I have turned off that DNS binding that causes issues with captive portals and still nothing, the only thing I have to mention, I did a test last night where I cloned the router to match my MacBook MacID and I was able to connect the router to the hotspot (connect - get IP - get captive portal page where I can login) but not this morning anymore. I says it’s connecting to the Hotspot wifi, but nothing happens (I don’t get any IP)

Thanks for any help…

Do you have the Cloudflare stuff turned on?

I’ve run into issues with captive portals that conflict with the DNS resolution…

I’ve seen this with Cisco/Meraki, straight Cisco, and Ruckus AP’s at various hotels - using the USB-150, but that should be same behavior with AR-300M

Work-around is to disable the rebind and cloudflare before attaching to the WLAN - one the signon is done, can re-enable.

One can also get in to a race condition if WG/OpenVPN is enabled before signin, and the workaround there is to let WG/OpenVPN timeout, disable it, and once logged in, re-enable the WG/OpenVPN client.


I don’t use Cloudflare at all, and neither the DNS

I have no idea why this isn’t working - last night I installed the test firmware 3.026 and reset the router and started fresh, even removed the Mac address clone, so it was basically the default router and I was connecting to the wifi hotspot directly from the laptop, and back to the router and trying the repeater then the captive portal popped on the router and I was able to use the hotspot via the router for about 12 hours, but today it doesn’t work anymore, and I have no idea what to do to reconnect.

One thing though that I discovered:
There is another internet hotspot with captive portal, close to where I live, if I connect to that via repeater function of the router, I get a Connected box in the Internet tab with the IP, Gateway, etc information for that particular hotspot right away, but with the hotspot I need to connect, I never get that… I am wondering if the hotspot I am connecting to is using some newer internet technologies that makes it that way and whether I need some IP of that hostname or its gateway to be added to the hostnames in network properties of the router in advanced section ?

FYI the Captive Portal I am trying to use is the WiFi for Orange (in France) - I am a paid subscriber, and I get free wifi… this used to work really well last year with the old firmware (blue screen) and WISP.

The redirection UI url is:

So if the router gets an IP once connected via the repeater function, by going to that URL I should get the login/password. Sometimes that page pops on its own…

that’s weird… but hotel wifi can be odd… so many different ways to do it.

I was at a Marriott property up in the Seattle area - in Client Mode mode, the USB150 would attach, but as soon as I enabled the client side SSID to share the connection to my phone, the network actively dropped the connect.

go figure…

This isn’t hotel wifi but actual Orange wireless hotspot in the city where I am currently visiting.

Last night I played around with this and was able to connect but today it doesn’t.

This is what I did.

  1. Add captive url / IP to hostnames of Gli router.
  2. Change the DNS on the router to &
  3. connect laptop to hotspot wifi SSID
  4. login via captive portal (check that I have internet)
  5. connect laptop to Gli router wifi SSID
  6. clone router mac address to be laptop mac address
  7. use router repeater option to connect to hotspot wifi SSID
  8. switch to hotspot wifi SSID and logout from captive portal
  9. switch to router wifi SSID and go to captive portal and login

Then I had wifi for about 12 hours, and when I got disconnected, I just go to captive portal url and logged in again.

Today after I am @ Step #7 I don’t get an IP from the hotspot, so I can’t go to captive portal url when connected to router wifi, because this time, the router repeater has not connected to the hotspot SSID even if it shows Success :frowning:

Ok I figured it out… if I omit #8 above and leave the connection to the hotspot wifi ssid from laptop and use the captive portal url from the router’s wifi ssid , I can then connect just fine from the router.

So the list is :

  1. Add captive url / IP to hostnames of Gli router.
  2. Change the DNS on the router to & (Google’s DNS)
  3. connect laptop wifi to hotspot wifi SSID
  4. login via captive portal url if it doesn’t pop (check that I have internet)
  5. connect laptop wifi now to Gli router wifi SSID
  6. clone router mac address to be same as laptop mac address
  7. use router repeater option to connect to hotspot wifi SSID
  8. use captive portal url and login


So unfortunately this stopped working altogether and I had to reset the modem. I even tried the old Lede 2.x from last year where connecting to Orange was working w/o a hitch, but noticed even that firmware now has issues, so the problem is with Orange - they probably changed their captive portal technologies.

There are three captive portal wifi hotspot close to where I live : Orange, SFR Fon & FreeWifi - all are from cell phone carriers. If I connect via my iPad or MacBook to them, the captive portal pops right away.

If I connect the Gli ARM300m to them via repeater, the SFR Fon & FreeWifi will show connected in Internet with their IP, Gateway, etc information, and their captive portal will pop but not for Orange which I need to use for my own connectivity (it just goes back to Internet page and I get nothing) - I am at a loss now on what to do.

Thanks for any help.