AR300M-Ext: Unable to flash NAND firmware, only NOR firmware works

A similar old post: GL-AR300M Unable to flash NAND (I was going to reply to it but the Discourse forum said I should make a new one)

Back in 2017 I bought one of these, an AR300M-Ext with the external antenna:

It had been running the 2.x firmware for a while and in those years I never upgraded it because it still worked fine. Today I randomly decied to upgrade to the latest 3.216 version via the web console. Unfortunately, I downloaded the wrong firmware, the version for the AR300M16.

Correct: (NAND, separate downloads for local upgrade and uboot)

Incorrect: (NOR, a single download for both local upgrade and uboot)

From all the docs and comments I’ve found online, the difference between the two are only:

  • AR300M
    • 128MB RAM, 16MB NOR Flash + 128M NAND Dual flash
  • AR300M16
    • 128MB RAM, 16MB NOR Flash

So, that was silly, but the router and web console still worked with the new interface and everything. I then tried to upload the correct NAND firmware for the AR300M, but the web console was just stuck saying “upgrading” for 10 minutes. I unplugged the router and tried to use the uboot method to upload the new correct firmware, but instead I was met with an error saying:

“Update Failed; Something went wrong during update. Probably you have chosen wrong file (too big or too small) or you were trying to updated ART on device with unknown FLASH type (and size) which is not allowed. Please, try again or contact with the author of this modification. You can also get more information during updated in U-Boot console.”

So then I tried the NOR firmware for the AR300M16, and that worked and I got the usual “Update in progress” screen.

So, for some reason I can’t upload the “proper” firmware for my AR300M and I’m not sure what to do. Any ideas?

Glinet have u-boot with art and radio file only by manufacture, in my experience the rom ic only cab flash with flash progammer like ch341A

Hopefully I can help you fix this issue. I bricked my unit, and this method worked.
Use the unbricking method, but when you need the firmware, use the basic OpenWRT firmware here: OpenWRT AR300M Firmware

After that, you can upload the correct AR300M firmware (if you want the GL.inet Firmware) via the upgrade panel. :slight_smile:

Also the current GL.inet beta is kinda broken, so it’s not recommended by me. :slight_smile:
Hopefully this helps and works for you. :smiley: