AR300M Firmware Update

Hello,

I just bought a new AR300M router. It detected the new firmware 3.024 is available and I clicked on the download firmware button to download it. However, after the downloading finished and I clicked on the upgrade button and the router rebooted, I’m still seeing the old version (2.27) after logging in. The SSID changed BTW. Then I repeated the download and upgrade process. However, this time it took a really long time and I couldn’t see the SSID showing up in my network after a long time. Then I tried unplugging the router and resetting the router etc. Nothing happened. I could no longer find the router in my networks. It seemed to be dead!

Any suggestions?

What does your total/free “disk” space show, either in the UI or with df -h on the command line?

My first guess is that updated NAND but are booted off NOR (or the reverse).

It’s dead now. I can’t see it in the networks and can’t connect to it!!! What should I do?

Windows isn’t the most robust at knowing what is on the network and not.

Setting a static address on your Ethernet interface (a second address, is ok) such at 192.168.8.2/24 and trying ping 192.168.8.1 would be the next steps.

If ping 192.168.8.1 doesn’t find it, then don’t panic

https://docs.gl-inet.com/en/3/troubleshooting/debrick/

Thanks for your reply. However, it looked like I need to use a ethernet cable to connect my computer to the router to debrick it, but I do NOT have a ethernet port on any of my computers (all laptops). What should I do?

Also, your suggestions are a little to technical to me. Please help in plain english. Thanks!

Yes, you will need an Ethernet cable and adapter and they are needed for many other things. They can be purchased for under US$20 for older and newer USB styles. I would recommend “GigE” (1000 Mbps) and USB 3.0, even if you’re current laptop doesn’t support USB 3.0.

thanks for your reply, but I don’t want to invest another adapter just to fix this router. Is there another way to debrick it (without using an ethernet adapter)? I bought it in china from Taobao. Can I return it if there’s nothing else I can do (without spending extra money)?

It’s unlikely that you bricked it, unless the power dropped during the flash.

You might try the reset-to-default feature on that same page.

Without an Ethernet adapter there are many things that become a challenge to impossible with any modern computer/networking equipment. It’s like at least one USB “stick”, you just “gotta” have one.

Taobao and seller’s policies are based on the terms of your purchase. If I were to guess, it will cost you more to ship back the unit than to buy a good-quality GigE Ethernet-USB 3.0 dongle from a reputable vendor (at least if you’re not in China).

Thanks for your reply. I guess I will have to order a Ethernet dongle then.

Another question: seems like I would need to download the firmware manually when I do the fix later. Could you please let me know the EXACT file to download for my GL-AR300M (internal antenna version) from this page: https://dl.gl-inet.com/firmware/ar300m/nand/v1/ ?

The reason I’m asking is that before I bricked the router, I did downlod the file “openwrt-ar300m-ubi-3.024.img” from the page above and tried uploading it to the router’s admin page to upgrade the firmware, but I was told it was the wrong version and failed. So, please let me know the EXACT firmware file for that router.

Thanks!

https://dl.gl-inet.com/firmware/ar300m/nand/testing/ – v3 firmware

  • .tar – for “normal” UI and sysupgrade use when running from NAND
  • .img – only for special recovery-mode (U-Boot) use

(Note that is different than OpenWrt, if you read any instructions over there)

Thanks for your reply. What do you mean by “this is different than OpenWrt”?

Naming of images for OpenWrt follows a slightly different convention. Same basic structure for each type of file, just a “you say ‘po-tay-to’ and I say ‘po-tah-to’” kind of thing.