AR300M-LITE: how to make wan port as lan port permanently?


#1

AR300M-LITE has only one wan port, but I plan to use it as wifi client.

Swift repeater mode, deleted wan and linked lan to eth0, works! but eth0 was always removed from lan after reboot.

Anyway can change wan port to a lan port? please advise!


#2

It should not auto revert to wan. Not sure why.

You saved the settings, right?


#3

Yes. definitely saved the change of setting, but eth0 always became unchecked after either reboot or power off.


#4

I read your solution about using the wan port as lan port. Is it possible to describe the process in detail how to change the wan port to a lan port in combination with WiFi installed with wisp. So I’m able to use my nas, which has only a lan connection.


#5

Just install firmware 3.0 and you can change wan to lan easily by one click.

https://docs.gl-inet.com/en/3/setup/mini_router/internet/


#6

Thanks! will find time to upgrade the firmware。


#7

Great, Thanks for the info.


#8

When I activated automatic firmware update, I got the message that 2.27 is the newest. Will the 3.0 version actually work on my GL-AR300M-Lite Mini Router, or will it brick the router


#9

It won’t brick the router, will work well on AR300M-Lite. Feedback is welcome if you found any bug.


#10

Thanks for the reasuring. Now to find the proper procedure to install version 3.


#11

upgraded to 3.010, cool web-gui. works very well! Thanks again!


#12

After the update my GL-AR300M-Lite was still connected to a wireless network, but no longer access to the admin panel.
A day later I tried it again and to my supprice the admin panel was now available.

After finding the switch for wan to lan. it took ages before the to the lan port connected window pc could reach the internet.
But after a while, after again connected to a wireless network, both devices (1 WiFi and 1 wired) worked well.
In the more settings department are some items that don’t work:
Admin password
Time zone
Mac clone
Custom DNS server
Revert firmware

Due to the instruction in the manual that was delivered with the router I used the repeater mode to couple to a WiFi network (hotel)
This function is not available in the network mode choices.


#13

Sounds like a browser cache problem.
Regarding other problems, try the new test firmware without saving settings.


#14

brought it during recent trip, works great in either wired and wireless mode. Very appreciated for your effort improving firmware, it becomes much more convenient and cute staff. Keep going!