AR300M loses config on reboot


just received my AR300M and started playing around.
I booted the router, changed hostname, network parameter and wlan parameter in the luci UI. After that, I selected reboot from the luci menu.
When the router came up again, it was not answering in the newly configured IP, and after checking, I figured out, it was sitiing in the setup wizzard again with all changes lost :frowning:
I tried different things, booting in NOR, booting in NAND, but it is always the same. After restart or power loss, the router starts with its factory settings.
Funny thing is, the root passwort is the only change that survives a reboot. So even though the router comes up with the config wizzard, I can manually naviagte to luci and login using the root password I set before rebooting.

What am I missing here? Is this a bug?

My router was delivered with fw 2.25 running on both flash partitions.

Nor firmware should not have problem.

When you boot into NAND firmware, do a “revert to factory status” manually and the router will reboot. Then try again.

Hi alzhao,

thanks for your replay!
So, first thing I realized today is, I was never really switching between NAND and NOR, since I did not ever ssh into the box and activate the switch for flash selection.
Restoring factory defaults via luci did not help, I think I already tried that yesterday, just because I did not immediately find the option in GLI UI. I used the GLI “reset to factory defaults” today and it work!

Here are some more observations, for anybody how might run into similar problems.

First thing, the default boot flash for my router was not NOR, what I assumed, but NAND. I verified via System -> Software in luci by checking free space. ~7MB = NOR, ~100MB = NAND.
After activating the switch for bual-boot and rebooting, I got a new SSID from the router with “NOR” in the name. Unfortunately I was not able to connect this SSID, since the default password (goodlife) was not accepted. So using ethernet, I changed password, IP and SSID for NOR system vie GLI UI. Then I tried to access luci to also change the hostname and some other settings, but it did not let me. Each click on System -> System brought me back to login screen again. I ended up also resetting NOR to factory settings via GLI UI. After that, everything seems fine now for both flash’s.

One thing I realized, the documentation of dual-boot feature on this page: Overview - GL.iNet Docs is actually wrong for my device. My router boots to NAND in default config, and also when setting the switch to left side (near reset). Switching to right (near antenna) boots into NOR.

Anyway, I’m happy my problem was solved this easy! I really like the AR300M!

Also thanks a lot to alzhao for his relentless help here in the forum. He was one key influence in my buying decision, additional to the cool features and size of the device.