AR300M + Tor 2.64

I tried getting this to work and I cannot for the life of me figure it out. I get the device connected and I am able to navigate the web. I switch the switch back to left and right(I might add the documenation page for connecting tor doesn’t show which is left or right very easily). Regardless I have put in both positions and it will not connect. I am able to connect just fine with TOR browser so not sure what the issue might be.

I have also went into system and serivce and stop/started tor and still doesn’t connect. I have tried 1 second hold of the button and that doesn’t work either. Please help.

Can you show the log of Tor?

logread |grep Tor

logread | grep tor
Thu May 10 19:30:15 2018 kernel: [ 5.190000] usbcore: registered new interface driver usb-storage
Thu May 10 19:31:13 2018 user.emerg syslog: chown: unknown user/group tor:tor
Thu May 10 19:31:13 2018 user.emerg syslog: chown: unknown user/group tor:tor
Thu May 10 19:31:13 2018 user.emerg syslog: chown: unknown user/group tor:tor

It should be “Tor”, not tor.

logread|grep Tor

Nothing found for that.

Can you also please clarify which is right and left is it when its facing you and you are looking at it? Right now I have the switch flipped towards the Reset button.

left or right side means from your view, not the router’s view.

But no matter which side it is, Tor should be running. Now Tor is not running at all. Did you disabled it and forgot to turn it on?

I have disabled and renabled it. I have stopped and started it. I have tried everything I can to get it to work. I don’t believe it is disabled anymore.

I am connected on the LAN interface via a wired connection. Will it work that way?

I had read some old documentation that there should be a tor wwan but I don’t see the SSID broadcasting out.

Keep in mind that I am connecting to the internet in repearter mode basically. The AR300M is connected on a wifi network and then I am connected to it right now via LAN interface.

the old docs is for old firmware. So omit it.

can you check if Tor process is there using ps

If not there try enable manually. /etc/init.d/tor restart

The firmware has a daemon which checks tor status so Tor should always be started.

Maybe you can reset your firmware to clear all settings then start over. Just to make sure you flashed the correct firmware without reserving old settings.

root@TheRouter:~# /etc/init.d/tor restart
root@TheRouter:~# logread | grep Tor
root@TheRouter~# /etc/init.d/tor restart
rroot@TheRouter:~# ps | grep tor
2423 root 1376 S grep tor

Tor is not started from the last command you gave.

Can you attach a screenshot of the main UI to make sure it is the correct UI.

Sorry I fell asleep and when I reset this to factory it wont come back up now. I get an IP from the device via DHCP but I can no longer hit the web interface. Is there a way to unbrick this router now?

It is now booting with 3 lights on 2 green and 1 red.

I tried following this guide and holding the reset button for 5+ seconds did not work. Are there any other options to get it out of this state?

Press and hold for 10 seconds and wait for the router to reboot.

I just went to bed and let it sit I can finally login to the web interface but it still the Tor firmware. How do I make sure I am running the right firmware for my current device. What commands can I run from the command line for you to review. I have a feeling I may have the wrong firmware.

Also TOR now shows 15% and has been stuck there for a while.

Ok I finally got it connected had to do /etc/init.d/tor restart.

However when I connect via the LAN interface and I do a check @

It says I am not connected. Should I be using another method to connect via tor?

I am still interested in confirming I have the right firmware installed so still keep that in mind for yoru next reply.

I haven’t heard anything back yet.

According to the docs, if you are using the UI you cannot connect to Tor.

You need to move the switch to the left side to use Tor.

If you move the switch, wait a little while (10 seconds) and check.

How do I tell which model I have NOR or NAND?

My model says gl-ar300m16-ext

Can someone please help with this?