AR300M uboot not flashing

Well, I tried compiling my own OpenWRT and adding the GL-iNet packages to an image built with the compiled image builder. It didn’t boot, and I guess because it’s a stock image it does not have the script to increase the boot counter to where it will boot NOR. It just constantly boot loops.

I’ve since had to find an ethernet adapter to connect to get to Uboot. As stated in other threads, Windows is useless trying to connect even changing the MTU settings. I’ve made a Kali Linux live boot USB. After setting the MTU to 900 I have been able to get through the Uboot web to the point it says it has been successfully uploaded (no resets). I see the LED lights flash like its writing, although it never reboots itself, and the Uboot web server still responds with the image upload page. I’ve tried 2.20, 2.264, 2.7 .img files from

After waiting for 10+ minutes and power reboot it is still stuck in a boot loop.

At this point I’m not sure what else to do with it - I’m pretty disappointed with the Uboot shipped with this version. I don’t have an FTDI adapter, and I doubt I will find one. I’m thinking of ordering the AR300M16-EXT to replace it depending on shipping costs to where I am traveling - but which has the best working Uboot restore functionality?

In this case, you can use UART to check what happens. UART Serial - GL.iNet Docs


I plugged in a 9 watt amazon usb power adapter, and gave it another flash (at 900 mtu) - previously I was powering it with my laptop. I’m not sure if this made any difference. Still no boot.

I booted it up after holding the button for 3 flashes, I think this puts it into serial console mode?

I had Wireshark up and was looking at the network and it appeared to be asking for openwrt-gl-ar300m.bin via tftp. I setup an tftp server and renamed a the NOR 2.27 .bin to this, the router grabbed it and flashed then rebooted.

Then it was asking for openwrt-ar71xx-nand-gl-ar300m-ubi.img. I did the same thing with a NAND img file.

Both the TFTP’s were done at regular 1500 mtu

I rebooted and tested both memory chips and everything seems to be okay now! :blush: