AR300M UBoot Problem

I have an AR300M. I have used UBoot many times in the past.

Since 2.25, I seem to be having a problem.

I believe I have the “old” uboot. 2.25 is on my NAND. I only use my NAND.

Uboot starts fine. When I load openwrt-ar300m-ubi-2.25.img, after a long time (10 minutes) nothing seems to be happening.

I disconnect the ethernet cable and reboot the router. The software comes back, just as I had it before the upgrade. There stock software is not reloaded.

I think my NAND ma be bricked but it is booting to NOR.

I tried re-flashing from the GLI firmware and it ony took the .bin NOR firmware.

Seems Nand firmware failed. Do you have USB-UART adapter using which you can check in details.

I’ve got both of my routers taking the .tar software “re-flash” from the GLI firmware. It doesn’t work with uBoot. I’ll be buying the UART from your website…

anyone know the commands to flash the TOR firmware to the NAND flash via UART,

any help or commands will be much appreciated

i am getting throught to the console just fine with a UART/TTL cable in 115200 bps, putty is displatying the AR300M-ext boot procedurejust fine!

but i think i am getting a crash at;
[ 39.770000] br-lan: port 2(wlan0) entered forwarding state

also what are the commands to factory reset via PUTTY UART method??

thanks in advance.

What do you mean crash? UART does not respond? Do you enter the Linux system?

The crash has stopped now, sorry i can’t remember what i did to stop it though, how do i use UART to change the firmware or factory-reset the router, what firmware do i upload to it? Will tor firmware work? Or will i have to install another firmware first??
i have the 128mb-NAND version, i was thinking eventually, once i got it back up and running normally, i was thinking of making it dual boot, the original firmware on the NAND flash and the tor firmware on the 16mb-NOR flash and making it so you can choose the different OS by flicking the physical-switch on the side of the router!
Oh yeah, do i have to rename the firmware openwrt-ar300m.bin or something similar if uploading via UART?
i read about doing something of the sorts, but for a different model GL-iNET router!

Thanks in advance and i know i’m probably asking a lot, but i do intend to use and know these routers as much as possible, i love them i think they have great potential.

Best routers u have bought in a long time, i even bought a “Slate” they seem better then my “Newifi Y1” which runs a software called pandorabox which is also quite a cool cheap box if anyone is interested in playing with them,

Aaaanyways, thanks again in advance for any help or suggestions.

I probably should have opened a new post for this (and will if asked.) Instead, I replied to this one because it describes my problem AND I am interested in the possibility of dual booting NAND or NOR as described by void-naught-zero-0.

Now for my real problem. I have the AR300M-ext and I am trying to flash it via uboot. I successfully did this once. I also successfully flashed OpenWRT via the router GUI (not the uboot page. Maybe it is called LEDE?!?!?).

However, flashing via uboot is failing for me now. I have tried it unsuccessfully many times and this is what is happening:

I upload the firmware from the uboot http page and all of the green and red lights flash continuously during/after the upload.
*the firmware I have tried to flash (the .img files using uboot) are the following:
lede-ar300m-ubi-2.27.img
openwrt-ar300m-ubi-3.024.img
openwrt-gl-ar300m-clean-2.264.img
openwrt-ar300m-nand-3.024.tar (this update was not uploaded via uboot and it worked)

So, I have (most recently) uploaded the “clean” image and left it all night. It is still flashing its lights in the following manner:
*** One green led on all the time (mostly).
*** After about 9 seconds, the middle green and the red light flash briefly while the main green light turns off (this is very brief.)
**** The main green light instanly turns back on and stays on.
*** Then, after a few more seconds, the red led blinks once, followed quickly by both the red and middle green light quick simultaneous blink.
*** This pattern then repeats ad nauseam. :wink:

I can send a gif/vid of the lights if it will help.
I appreciate any advise on what may be wrong or what is causing this. Better still, would be instructions on fixing this awesome little router! I am asking here before returning item as defective. Thanks for any help.

Cheers!

I should have added this info too:

I have tried NAND flashing using firefox 60.8 ESR on both Debian 10 Buster and Fedora 30. I have also tried it using chromium on Debian 10. All Fail.

The LED action shows that your firmware cannot boot and the device is trying to reboot again and again.

Did you flash the clean image (openwrt-gl-ar300m-clean-2.264.img) to the Nand (the first file box)?

Do you have a UART adapter?

I had to update the “uboot firmware” ITSELF, before I could flash the “Nand firmware” as the latter was failing everytime (I was in a infinite boot loop!) I found this reference to flashing the “uboot’s firmare” (192.168.1.1/uboot.html) ITSELF here: AR-750S Uboot recovery not working .

That was successful and then i was able to flash the “Nand” firmware successfully.

NB. I did NOT have to use windows to flash the uboot firmware. I used firefox with gnu/linux.

Unfortunately, I flashed the (root/firmware/ar300m/nand/v1/openwrt-ar300m-ubi-3.024.img) and am wondering why I have no 5ghz wireless. The radio is not setup in the advanced part of the router GUI. Hmmm. Should I flash the version you suggest or can you supply a config that will set the system to default? Maybe, I should just add the radio1.network1 as the 5ghz. I must say that this is over my head already.

Is there a detailed tutorial somewhere?

Please advise. Thank you.

***EDIT: Changed firmware/ar300m/v1/openwrt-ar300m16-3.024.bin to root/firmware/ar300m/nand/v1/openwrt-ar300m-ubi-3.024.img

I have flashed the openwrt-gl-ar300m-clean-2.264.img, openwrt-ar300m-ubi-3.024.img and openwrt-ar300m-nand-3.024.tar (from the GUI on both .img firmwares.) In all cases, I have to 5ghz wifi.

Any advice on getting tthis router back to the default?

Thank you.

Also, in my last post I incorrectly stated I flashed the “openwrt-ar300m16-3.024.bin”, when I actually installed “openwrt-ar300m-ubi-3.024.img.” Ugh.

Do you have one AR300MD (dual band) version?

AR300M series only as 2.4G wifi. Only some users has a experimental dual band version. So you should be one of them?

The default firmware does not have 5G of course. If you have AR300MD, you need to install ath10 driver and reboot the device so 5G wifi will come back in Luci.