AR300M: yate installs with segmentation fault

I have two GL-iNet routers:

  • MT300A with OpenWrt Chaos Calmer 15.05 r47065 / LuCI for-15.05 branch (git-17.136.58961-13aa5ff), kernel 3.18.27

  • AR300M with LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)
    , kernel 4.4.92

On both I tried to install the software package yate.

On MT300A I got the following result:

opkg install yate
Installing yate (5.5.0-1-1) to root…
Downloading 404 Page not found - GL.iNet.
Configuring yate.

On AR300M I got the following result:

opkg install yate
Installing yate (5.5.0-1-1) to root…
Downloading 404 Page not found - GL.iNet
Configuring yate.
Segmentation fault
/etc/init.d/yate start
Segmentation fault

On both routers it’s the same version of yate, only the hardware, the firmware and the kernel are different. Does anybody have an explanation for this different behaviour? Is there any chance to get yate running on the AR300M?

Thanks for reading and have a nice day.

Barney

We aren’t experienced in yate. The cpu architecture of two routers are different. It may causes the problem.

I will guess that it requires floating point computation and it segfaults like nodejs or go compiled programs do. The kernel compiled for 2.7 firmware does not have it enabled. If you try the older firmware on the AR300M (2.264) it has FP emulation enabled in the kernel.

@nopro404

Thanks for your reply. I’ll give it a try.

Is this the correct image for flashing from the Web-UI?
http://download.gl-inet.com.s3.amazonaws.com/firmware/ar300m/nand/v1/openwrt-ar300m-nand-2.264.tar

Barney

looks like that should do it

@nopro404

I’ve flashed my AR300M with openwrt-ar300m-nand-2.264.tar and yate installs now without segmentation fault. Your supposition about missing floating point computation seems to be correct. What about enabling FP emulation in newer kernels?

Okay, yate is now running with openwrt firmware 2.264, but there is a new problem: the repositories /openwrt/ar71xx_nand/2.264/packages/ do not contain any packages for adblock. :frowning: See my related post in a new thread.

Doh! Yeah have to bug @kyson-lok to get a build with MIPS_FPU enabled :smile:

yeah! It seems that the problem caused by firmware without enable MISP_FPU.

Is there any chance to get a MISP_FPU enabled kernel?

Barney