AR300MD: which firmware do we use now?

I’ve got a gl-ar300md and, in the past, users of this device were told to use the 3.03 firmware. I had endless issues with firmware 3.03 with DHCP not working properly, super weak signal when connecting to 2.4Ghz networks, and the lede firmware regularly seeming to treat both radios like there was only one when adding/removing networks.

All of these issues were magically fixed by flashing to 2.x firmware, but I would immediately lose access to the 5Ghz radio.

I see that the 3.03 firmware isn’t even on the website anymore. It now says under the testing folder readme.txt:

lede-gl-ar300m-* is for Dual band AR300M with ath10k Driver

That implies to me that I should be able to flash my AR300MD with lede-gl-ar300m-nand-2.27-testing.tar to get a firmware that supports the 5Ghz radio. I did this, and my firmware is stable (no DHCP issues, no signal issues), yet the 5Ghz radio is nowhere to be found. I tried installing the kmod-ath10k package and rebooting, but I’m still not seeing the 5Ghz radio.

What am I missing?


Solution

The trick is to install lede-gl-ar300m-nand-2.27-testing.tar then install the following two packages for the AR300MD to gain access to the 5G radio:

  • kmod-ath10k
  • ath10k-firmware-qca9887

I also tried it with the kmod-ath10k package and the ath10k-firmware-qca9887-ct firmware and that worked as well.

Disclaimer: If you are not comfortable fiddling with settings in the advanced/lede interface, I strongly recommend not installing the ath10k driver as it causes super weird problems when managing wireless networks in lede. I did not experience any such problems prior to installing the 5G driver.

Detailed Instructions

  1. Download and install the latest testing firmware for AR300M (v2.27 at time of writing) here. I’m guessing the release firmware for the AR300M should work as well, but I haven’t tested it.

  2. Once installed and your AR300M has an Inernet connection, open the advanced/lede firmware (link in upper right corner of stock firmware), then go to System > Software > Available Packages tab, then using the filter field and entering “ath10k”. Install kmod-ath10k and ath10k-firmware-qca9887 then reboot the router (System > Reboot)

  3. Your 5G radio should now be available to use in both the stock firmware and advanced firmware. Maybe you’ll somehow avoid the weird issues I encountered when managing wireless networks within LEDE with the 5G radio enabled, but if not, move on to step 4 to learn how to solve them.

  4. Solving weird LEDE issues when the 5G radio is enabled. For unknown reasons, my strange issues (described at the following link) were solved by reconfiguring both the 5Ghz LAN connection and the 2.4Ghz LAN connection (Not the WAN connection) to use AP-WDS mode (rather than the default ‘AP’ mode). See this thread for more details on the issues and how this solution was found.

Maybe missing the 5GHz config. You can refer to this config:

# cat /etc/config/wireless 

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option txpower '15'
	option band '5G'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'GL-AR750-c8b-5G'
	option encryption 'psk-mixed'
	option key 'goodlife'
	option ifname 'wlan0'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option path 'platform/qca953x_wmac'
	option htmode 'HT20'
	option hwmode '11ng'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'GL-AR750-c8b'
	option encryption 'psk-mixed'
	option key 'goodlife'
	option wds '1'
	option ifname 'wlan1'

Sorry for the old info.
Firmware for AR300MD is removed from the folder and now it is for AR300M only.

But you can install ath10k driver using opkg in your current firmware and reboot your router. Then have a try.

I think I have the old firmware for AR300MD somewhere and need to find it.

I installed the kmod-ath10k package. Is that not sufficient? It’s not clear to me which of the ath10k driver packages I should install as they refer to two different device IDs. Could you point me towards the correct one?

kmod-ath10k
ath10k-firmware-qca9887

Thanks! That does the trick to get the 5G radio back.

Installing missing packages to enable 5GHz radio is not a problem – the problem is how to obtain/build the vanilla LEDE/OpenWrt firmware compatible with AR300MD as it rejects images built for AR300M16.

how to obtain/build the vanilla LEDE/OpenWrt firmware compatible with AR300MD as it rejects images built for AR300M16.

As mentioned at the top of this thread, my AR300MD took the testing firmware “lede-gl-ar300m-nand-2.27-testing.tar” with no problems at all. I know it’s not vanilla, but it comes with LEDE… why not use that?

It is a problem of Nor and Nand.

AR300M16 firmware is only for Nor firmware. While AR300MD uses Nand firmware.

Updated to openwrt-ar300m-3.203-0701

Seemed to work for a while, however if it loses power while the 5G radio is enabled, when it reboots it will boot up, engage the 5G radio and then about 3-5 seconds after enabling the 5G radio it will crash so hard that it no longer responds to ping. It reboots itself, then repeats that same process.

To bust it out of that reboot loop, I booted to uboot, reflashed with the same firmware above. The first time this happened, it worked and I was able to set it up again. The second time it lost power (I cut power to the socket from the breaker) even a reflash of the same latest firmware listed above didn’t help – continuous crash/reboot cycle as described above.

I flashed again from uboot using openwrt-ar300m-ubi-3.024.img which got me back into the web interface, disabled the 5G radio and upgraded to the latest firmware again (from GUI), keeping the 5G radio disabled. It works great on the latest firmware with no 5G radio. When/if I have more time to test, I will try configuring the 5G radio with low power output to see if that helps keep it stable.

I totally understand that this is legacy hardware and that the 5G module isn’t supported and was never found to be stable. That said, it might be nice if the firmware’s crash handling/management could auto-disable the 5G radio on boot. That way even if the user purposefully enables it and causes serious crashes like this, it won’t be so bad that the admin GUI can’t even be loaded.

The 5G chipset 9887 driver should be good to run. But may not be well configured.

AR300MD is limited version for hobbiest, sorry no maintenance