AR750 Fails to upate packages


#1

I updated my AR750 to 3.003. It connects to the internet through the modem both on LAN and as a Wifi-Repeater, allowing me to surf the internet BUT its failing to connect to wireguard AND its failing to download pacakges!

I have tried reinstalling software 2.263, 2.272 and 3.001 and 3.003 through the standard GUI and also through UBOOT web UI…

Basically this is the log:

Downloading http://download.gl-inet.com/releases/kmod-3.0/ar71xx/generic/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/kmod-3.0/ar71xx/generic/Packages.gz

Downloading http://download.gl-inet.com/releases/packages-3.x/ar71xx/base/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/packages-3.x/ar71xx/base/Packages.gz

Downloading http://download.gl-inet.com/releases/packages-3.x/ar71xx/gli_pub/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/packages-3.x/ar71xx/gli_pub/Packages.gz

Downloading http://download.gl-inet.com/releases/packages-3.x/ar71xx/packages/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/packages-3.x/ar71xx/packages/Packages.gz

Downloading http://download.gl-inet.com/releases/packages-3.x/ar71xx/luci/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/packages-3.x/ar71xx/luci/Packages.gz

Downloading http://download.gl-inet.com/releases/packages-3.x/ar71xx/routing/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/packages-3.x/ar71xx/routing/Packages.gz

Downloading http://download.gl-inet.com/releases/packages-3.x/ar71xx/telephony/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/packages-3.x/ar71xx/telephony/Packages.gz

Downloading http://download.gl-inet.com/releases/packages-3.x/ar71xx/glinet/Packages.gz
*** Failed to download the package list from http://download.gl-inet.com/releases/packages-3.x/ar71xx/glinet/Packages.gz

Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Failed to establish connection
Collected errors:


#2

The same thing happens to me with a GL-MT300N-V2:
Downloading http://www.gl-inet.com/lede/2.271/ramips/mt7628//Packages.gz
*** Failed to download the package list from http://www.gl-inet.com/lede/2.271/ramips/mt7628//Packages.gz

Failed to establish connection
Collected errors:

opkg_download: Failed to download http://www.gl-inet.com/lede/2.271/ramips/mt7628//Packages.gz, wget returned 4

#3

@androidcuba @Taigerr

Could you have a try on your browser? Pls open your chrome browser, then input the URL http://download.gl-inet.com/releases/packages-3.x/ar71xx/glinet/Packages.gz on the address bar. Just want to see if there is someplace can’t access our s3 server.


Change of language in LuCi
#4

Hi Kyson-lok. Firstly thanks for your quick responses. This is why I stick with GL.iNet products.
As a test I put the modem into bridge mode and put the AR750 into PPPoE and this fixed the issue.
It appears my modem had somehow partly bricked on reboot from an earlier power failure (we are in a rural place) and I think this lead to problems with the DNS as I had put custom ips in the modem.
I have since updated and reinstalled my modem firmware and reconfigured it and now everything is back to normal.
Again thanks for the quick support!!

Just to add I got a slate for travel and its performing really well so far and I highly recommend it.


#5

Thanks for your feedback. @androidcuba Are you in the same situation?


#6

Writing the URL of the download page in any browser I can see it perfectly, but when I try to update from my GL-MT300N-V2, what can I do?


#7

How are you connecting the mini router to the Internet? via repeater, WDS?

Seems the router can do NAT but do not have Internet itself. This only happens in some bridge mode in my experience.