AR750 - Need assistance setting up Access Point mode

your router is still in router mode.

so pls confirm what you have done.

https://forum.gl-inet.com/uploads/default/original/2X/3/321ddfb2174f45f3eed56aa822a85be3887c5e10.jpeg

Based on this photo, you go to more settings -> network mode and select AP?

You’d better make a short video so that everything is clear.

That is correct: More Settings, Network Mode, AP, Apply.

AP is set to DHCP on internet page. I do have a secondary set of WiFi connections that do differ in name vs the main router. The secondary router only talks to main router via Cat6 100ft cable. Cable is plugged into WAN port. The switch is not setup to do anything in the software, so we can ignore the switch position. Nothing else I can think of that I have done.

I’m sorry, I do not understand what you need a video of/for.

I have an AR750S-EXT and I am experiencing the same error message “WARNING: No cable is plugged into the WAN port!” when I try to switch to AP mode. I found this page when searching for the error.

I have a device connected on the WAN port, the error message is not correct. Also, I tried using the option “WAN port has been used as LAN. You can set it back to WAN below.” in the Internet page as well. This did not help either.

The only reason I bought this device is because I want AP mode, where it simply passes packets from one of the ports on to the WiFi, so I really need this feature to work. I’m running the latest firmware 3.025 compiled on 2019-06-26 11:15:03.

Thanks!

Can you access the Internet normally using WAN port?

I tested 3.026-0729, and there was no problem

This is the result of my test, there is no problem like yours.



Hmmm, so I rebooted everything, connected the device to a different network, and then configured it, and it did not complain. Then put it back onto the test network I really want to work with, and it is still working. Not sure what is going on here.

What is the criteria for detecting something on the WAN cable? Does it need to get a DHCP address, or just have a cable connected and powered up?

Need to be able to get the DHCP address.
The reason for this is that if the device can’t get the IP, after switching to bridge mode, the device cannot be managed

Thank you fro the updates everyone! I’ll try a reboot and connect to the router via direct connection to WAN to see if I can get it to work that way.

Interesting you bring up bridge mode. How can I tell if my router is in bridge mode or not?

I do not have 2 networks to work with like waynepiekarski does (good job getting it to work!). I know the router is getting DHCP address from the main router. It appears to on the router internet page and I see it in the main router’s table as well. Perhaps it is not getting an address properly? But then I wouldn’t have internet connection from it… When I do.

I will try and circle back the next chance I get!

Thanks!

@luochongjun what if I can’t use DHCP? I don’t want the router to grab an address because due to other reasons, the device I have can only hand out one valid address. I would like to set the router to use a static IP.

Is the code explicitly checking for a DHCP lease?

I’ve been testing this more today. You definitely have to have DHCP working on some other network first. Then you can enable AP mode. Then you can login to the router again, there is an “Advanced” tab, where you can go to the OpenWRT configuration, change the IP to static, set it to whatever you want, and then save it. Its not elegant, but it works eventually. It would be nicer if AP mode just let you set it if the IP is set statically already.

You are totally correct. Let’s find out how we can do that.

The problem needs to be solved, how does a user know the correct IP address he need to use?

@alzhao I have set the router to a static IP (instead of DHCP), so I can connect to the router later on.

Currently, it seems like the logic only checks for a DHCP server, and if so allows AP mode.

I’m asking that you either remove this check, provide a warning, or check that the device has an IP from either DHCP or static.

I think we may just provide one option when you set up AP/Extender to let you an IP address. As we only got one requirement on this and once we add this, we need to deal with a lot of more issues, we will not be urgent to do this.

My main router and the AR750 both are using DHCP so at this point the main router does not meet the current minimum requirements as I still receive the message. To be honest, I feel the AR750 was a bit faster to connect to the internet when it was set as static as the system did not have to utilize DHCP on both routers. However, it is but not a big deal.

Eventually I will hope to update to the firmware which may fix this check in the future. For now, it appears I will have to be patient and wait.

I may need to purchase a replacement router soon as it seems the connectivity reliability may be going down as of a couple weeks ago. However, that is a different topic entirely.

Thank you all for your responses. It is greatly appreciated!

I suggest adding an option for the user to choose DHCP or static… Then it is up to the user to know the difference. Besides, the end-user would assign a static IP from the main router/network. At this point they should know to set the same IP to the AP. Giving a choice and recommending the DHCP option would help steer the less experienced in the proper direction.

Besides, the “anti-brick firmware installation recovery” process is genius for any issues that arrise. I have had to use it once myself a long time ago!

Hello, I’m setting up a GL-MT300N-V2-3a1 to be the access point for my modem/router, so that I can create a WI-FI network connected to a VPN, which my old router cannot use.
I’m reopening this thread because your experience could be of huge help, but I don’t know if the different router could be a problem; in that case please advice and I’ll open a new thread.
The VPN router is connected to the other one through a LAN cable entering the WAN port. DHCP is set and I can access the internet; no VPN is set by now. Current version is 3.102, no updates available.

When trying to change network mode to access point the ui complains that no cable is plugged into the WAN port, which is false.

How can I solve this?
Thank you all

Marco

There is a 3.104 here.

https://dl.gl-inet.com/firmware/mt300n-v2/testing/

Can you download and upgrade manually?

Thanks, but the upgrade didn’t solve

It is better to use a separate thread because you are working on a different product other than AR750, which is in the title.

I just treid 3.102 firmware and I do not have this problem.

This should be a bug in a very old firmware. But not in 3.102 and 3.104. What browser are you using?

BTW, if you set up as bridge, you cannot use as VPN client.

So isn’t it there any chance to have the same network as the modem and the VPN together?