AR750 - Need assistance setting up Access Point mode

Hello, I am new here, hope I post this in the correct category. It is router > software related after all…

First, I would like to make sure it will be worth it to change my AR750 (not S) to Access Point mode. On my system, I get 12ms ping time from my first router to (wireless), and roughly 14-15ms to ping from the AR750 (wireless). (ping from cmd to is the same as well)

With that said, I attempt to change the router to AP mode via Web UI > More Settings > Network Mode > Access Point > Apply… I receive the error WARNING: No cable is plugged into the WAN port!, even though my connection is per the WAN port. I could not find anything on this online, logs, or documentation. This is the thing stopping me from moving forward…

I have the first router attached to AR750 via gigabit NIC on router to WAN port on AR750. What I would like to do is use it as an AP. I have tried the latest firmware, including the “test” version. Currently on test version 3.026. (tested on 3.010 as well)

I am not very experienced with working with the interface, which is where I could use some help. I checked Google for a few hours and followed several official documentation pages and fall short.

Please let me know if there is any other information needed. I think I got all the important information…

Thanks in advanced!

I did see the option per the link below that was interesting and I was wondering if it will work for the AR750. Post near the bottom [alzhao] from Jul 2016

This is likely a bug in the old firmware. If you tried 3.026 and this still happens, I will ask engineers to have a check.

Hello alzhao, thank you for the information. I hope this is a common issue as then it would be fixed easier. I will be awaiting the response from the team!

Thank you!

I just tested it, but I didn’t come across this issue.

Could you please take a screenshot of INTERNET page?

Here you go! The primary gateway is I have a DNS ad filter at I attempted to use and my ISP’s DNS here, made no difference.

You should use DHCP protocol.

I will try that this weekend. Thank you!

Changed to DHCP, got the same message when attempting to change to Access Point mode. I rebooted and tried again, no change.

If you change to DHCP, does the router can acquire IP address?

The router says it is offline and cannot connect to the internet. The web interface shows this message when I browse other settings.
“No Internet Connection! Find new networks to reconnect.”

However, not sure that is matters, I have all my wireless devices connected to it with a 192.168.8 address and yet all the devices do have internet access. Several smart home objects and two laptops.

I checked the main router, a 10.0.0 network and see the same objects have a 10.0.0 address. My devices are not configured to connect wireless through the main router. I feel this router is pointing the objects to the main router for internet connection. Not sure how that works or if that is true. Though, knowing this may help.

Is it possible my router is already in AP mode? When I check the mode page, it has Router selected. I assume the page defaults to what is used. But maybe not? I see no indicators on the mode page that shows what mode I am using.

your router is still in router mode.

so pls confirm what you have done.

Based on this photo, you go to more settings → network mode and select AP?

You’d better make a short video so that everything is clear.

That is correct: More Settings, Network Mode, AP, Apply.

AP is set to DHCP on internet page. I do have a secondary set of WiFi connections that do differ in name vs the main router. The secondary router only talks to main router via Cat6 100ft cable. Cable is plugged into WAN port. The switch is not setup to do anything in the software, so we can ignore the switch position. Nothing else I can think of that I have done.

I’m sorry, I do not understand what you need a video of/for.

I have an AR750S-EXT and I am experiencing the same error message “WARNING: No cable is plugged into the WAN port!” when I try to switch to AP mode. I found this page when searching for the error.

I have a device connected on the WAN port, the error message is not correct. Also, I tried using the option “WAN port has been used as LAN. You can set it back to WAN below.” in the Internet page as well. This did not help either.

The only reason I bought this device is because I want AP mode, where it simply passes packets from one of the ports on to the WiFi, so I really need this feature to work. I’m running the latest firmware 3.025 compiled on 2019-06-26 11:15:03.


Can you access the Internet normally using WAN port?

I tested 3.026-0729, and there was no problem

This is the result of my test, there is no problem like yours.

Hmmm, so I rebooted everything, connected the device to a different network, and then configured it, and it did not complain. Then put it back onto the test network I really want to work with, and it is still working. Not sure what is going on here.

What is the criteria for detecting something on the WAN cable? Does it need to get a DHCP address, or just have a cable connected and powered up?

Need to be able to get the DHCP address.
The reason for this is that if the device can’t get the IP, after switching to bridge mode, the device cannot be managed

Thank you fro the updates everyone! I’ll try a reboot and connect to the router via direct connection to WAN to see if I can get it to work that way.

Interesting you bring up bridge mode. How can I tell if my router is in bridge mode or not?

I do not have 2 networks to work with like waynepiekarski does (good job getting it to work!). I know the router is getting DHCP address from the main router. It appears to on the router internet page and I see it in the main router’s table as well. Perhaps it is not getting an address properly? But then I wouldn’t have internet connection from it… When I do.

I will try and circle back the next chance I get!


@luochongjun what if I can’t use DHCP? I don’t want the router to grab an address because due to other reasons, the device I have can only hand out one valid address. I would like to set the router to use a static IP.

Is the code explicitly checking for a DHCP lease?

I’ve been testing this more today. You definitely have to have DHCP working on some other network first. Then you can enable AP mode. Then you can login to the router again, there is an “Advanced” tab, where you can go to the OpenWRT configuration, change the IP to static, set it to whatever you want, and then save it. Its not elegant, but it works eventually. It would be nicer if AP mode just let you set it if the IP is set statically already.