Ar750, openvpn, dns - nothing works. What's the trick?


#1

well… this is one of this at my wits end posts.
I’ve bought almost every gl-inet device and, by and large, I like them. But I keep hoping every one of them will fix the DNS problem. I’ve tried the up/down scripts. I’ve tried changing manual DNS addresses. Nothing seems to work.

Is this just a a critical flaw and there’s nothing to be done? Or is there something that actually works? It’s almost a deal breaker for me.

I love that I can plug the device in and get in on a network and boom, my OpenDNS is up. But it’s virtually worthless (besides, well, you know the security benefits)…none of my internal addresses resolve.

If I do an nslookup and change the server to my internal server, everything resolves fine. I can change each client manually, but that’s not sustainable.

The last thing I tried is this:
-script-security 2
up /etc/openvpn/updns
down /etc/openvpn/downdns

But openvpn complains -script-security 2 is invalid. If I comment it out, the VPN connects, but there’s no joy.

up looks like this:

#!/bin/sh
mv /tmp/resolv.conf.auto /tmp/resolv.conf.auto.hold
echo $foreign_option_1 | sed -e ...s/dhcp-option DOMAIN/domain/g... -e ...s/dhcp
echo $foreign_option_2 | sed -e ...s/dhcp-option DOMAIN/domain/g... -e ...s/dhcp
echo $foreign_option_3 | sed -e ...s/dhcp-option DOMAIN/domain/g... -e ...s/dhcp

and down is:
#!/bin/sh
mv /tmp/resolv.conf.auto.hold /tmp/resolv.conf.auto

I’d sure be grateful for any tips that work. Thanks y’all!


#2

Which firmware version are you using?

The up/down scripts only work when your server will push DNS to client.

If you set a custom DNS, it should work. How did you test it?


#3

thanks Kyson-lok

I’m on version 3.009.

I’ve go the scripts working and I can successfully resolve remove hostnames over the VPN on the router itself.

However, none of the clients connected to the router are able to resolve any hosts. If I explicitly set the DNS server on met clients, they work fine. But they aren’t able to resolve remote hosts over the vpn if the DNS is 192.168.8.1 (the router)

I’ve been using this post as my guide: AR750 as OpenVPN client, no DNS for far network