AR750 Problems

Hello. I got the AR750 router because it was the only one that i could find, ever, that allowed me to connect a modem via a usb port. This is such a simple concept but every other router on amazon that has a usb port, but you cannot use a usb modem in. Makes no sense.

I have a Global Telecom Netstick Usb Modem, from Sprint. I got this device simply to avoid using my phones hotspot, because if i am away from home, my siblings will no longer have connection. Also, I did not go with a dedicated hotspot device because of battery issues. I went through 2 different hotspot devices and both times the battery swells because I did not baby sit the device.

Now, my problem is that whenever I go to use the internet, my modem just restarts. This makes playing games undoable since i rely on a stable connection, and being disconnected constantly is just a terrible experience.

Another problem is that on random, the router simply denies internet access. I can be on an offline game, and I get the notification for using the Discord overlay multiple times in the session, as if my internet just turns on and off at random. Also, I was sitting at my desk doing nothing a minute ago, and I notice multiple times my task bar shows no internet access, for no reason. Shortly after it would re connect, but it would simply go out again and again. The last time this has happened, the connection did not come back, I had to restart the device.

I really need some help because I contacted support and they have not replied yet. Like I said, this was the only kind of router that works in my situation. I would really hate if this is an unfixable problem, and I cannot use this modem for what I originally wanted.


First question, are you using the power supply that came with the AR750? If you’re not is it possible the USB port on the AR750 isn’t supplying sufficient/proper power to the USB port to run the Netstick?

Yes, i even switched for a more powerful power brick and i still get the problem.


Couple of other basic(s) (Sorry, but I’m trying to go through logically).

  1. You have the latest firmware on the AR750 (3.104)
  2. You’ve turned off the WiFi on the Netstick?
  3. Does the same thing happen if you connect to the AR750 via ethernet?

I have used multiple USB 4G modems on multiple Gl.iNet devices with no issues (though not Netstick) :frowning:


1 Like

Actually, the problem seems to only occur on the ethernet connection. I get the no internet access on my computer, connected via ethernet, but my phone connected to the 2.4g is still playing videos. I am trying to update firmware right now.

nevermind, the problem is across the entire network. I can use it for a little while tops, and then suddenly i am getting no internet access. I couldnt keep the connection on long enough to download the firmware update.

Ok. I have updated the firmware, its been a few hours and i have not run into the problem yet. I will update you guys either tomorrow or the next day, to confirm if this really solved the problem. Thank you @limbot for your help.

Yep, that did it. Thank you.

Fantastic! :slight_smile:

Glad it’s all working now!!! :slight_smile: