AR750 tethering with Oneplus 5T, doesn't work

Hi all

Topic says everything, just tried tethering and on web interface I see only No phone device connected.
logread :slight_smile:
Thu Apr 26 16:29:20 2018 kernel: [22347.863721] usb 1-1.2: USB disconnect, device number 6
Thu Apr 26 16:29:20 2018 kernel: [22348.124136] usb 1-1.2: new high-speed USB device number 7 using ehci-platform

Seems the phone is not recognized. Are you using firmware 2.27?

Yes im using latest 2.27

I don’t have Oneplus 5T but I have a HTC. Just tested on AR750 v2.27 and it works.

Oneplus is China brand and generally they modify the system heavily.

Have you tried enable and disable the tethering, or unplug and replug multipe times?

Same problem here with a Nokia 8 running Oreo 8.1 - receive the same log messages as MucFlyer. And the Nokia 8 runs stock android.

I would say, oneplus is one of closest one, to pure android. It is not being heavily modified.

have you disable/re-enable usb tethering on the phone after connected to AR750? that what i did on my Pixel/Pixel 2

Tried that (and lots of other things) on my Nokia 8 - no joy. It tethers fine by USB to Windows 7.

I might be able to shed some light.

I think with the current release of OpenWRT, esp since the merge between LEDE Project and OpenWRT as of 1/2018, some minor, non obvious, changes occurred with the way the USB device was presented within the system log and the clear omission of the interface identifier. In my specific case, I’m using iOS 11.3.1 on an iPhone 6.

Traditionally the device has been named ‘usb0’, however with my GL-AR300M w/ the 128MB of NAND, I wasn’t able to get this work.

  • I manually created the interface, no joy
  • I verified the libraries were installed and even tried reinstalling them, no joy
  • I connected the unit to an internet connection and auto-updated the firmware from 2.264 to 2.27, no joy

I finally found a reference regarding OpenWRT. It showed that I had to manually edit /etc/config/network (I used vi) to add a new interface. I added the following lines:

  • config interface ‘TetheringWAN’
  •   option proto 'dhcp'
  •   option ifname 'eth2'

Basically eth2 was mentioned as the interface instead of usb0 in the OpenWRT reference and this solved my issues. For whatever reason the OpenWRT/LEDE team in the most recent releases of OpenWRT don’t use usb0 anymore for network interfaces.

If you are a little more comfortable w/ linux, you can just list the interfaces by using ‘ifconfig’.

I don’t know why your device change from usb0 to eth2. My iphone always tether as eth2 and my andriod always tether as usb0.

But all should be seen in the UI.


The point is that the OS recognizes the device as being present, but it doesn’t mention what the interface is:

Thu Apr 26 16:29:20 2018 kernel: [22347.863721] usb 1-1.2: USB disconnect, device number 6
Thu Apr 26 16:29:20 2018 kernel: [22348.124136] usb 1-1.2: new high-speed USB device number 7 using ehci-platform

– It’s an OS issue. You’ll note that @MucFlyer doesn’t add anything else besides those two lines because in the dmesg output, there is nothing else. The OS doesn’t automatically create the interface properly in 2.264 or 2.27.

However, my iPhone tethers with no problem in Apple Mac OS X

I understand what is the problem. But don’t know the reason. I have iPhone 6s, iPhone X but tether.

Be sure to check the iPhone screen and tap Trust the computer if it asks.

Unplug and replug the cable, disable and rename the hotspot in iPhone sometimes do the magic.

@alzhao I tried that. Didn’t work. Manually creating the interface was the only way. I can imagine that if you modify the firmware to add the interface already, then there would be no problem.

Why not just pre-make the interface for ‘usb0’ and for ‘eth2’ in the next release?

Easy fix.

Thanks for the info @kalieaire. I have tried your suggestions (using eth1, eth2, usb0, usb1, usb2) and still can’t get it to tether to my Nokia 8 running Android 8.1. As stated previously, the phone tethers fine to Windows 7.

Log message when the phone is connected below, but the same issue as @MucFlyer with his Oneplus 5T.

[ 1140.507976] usb 1-1: USB disconnect, device number 6
[ 1141.177410] usb 1-1: new high-speed USB device number 7 using ehci-platform

before making changes, what was the output of ‘ifconfig’ ??

Seems the phone is not recognized.

please try
ifconfig -a

I’ve done a bit more digging and it would seem that the RNDIS driver isn’t being loaded for the device. From /sys/kernel/debug/usb/devices I’ve got the following:

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 4 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0489 ProdID=c022 Rev= 4.04
S: Manufacturer=HMD Global
S: Product=Nokia 8
S: SerialNumber=X
C:* #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
A: FirstIf#= 0 IfCount= 2 Cls=ef(misc ) Sub=04 Prot=01
I:* If#= 0 Alt= 0 #EPs= 1 Cls=ef(misc ) Sub=04 Prot=01 Driver=(none)
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=32ms
I:* If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)
E: Ad=8e(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=0f(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms

I think where it states Driver=(none) it should be showing Driver=rndis_host. I’ve read about USB mode switching, and am pretty sure the mode is correct as the vendor and product IDs listed here are the same as when it successfully tethers to Windows 7.

So, any idea why the RNDIS driver isn’t loading for the device, and how I can attempt to resolve this?

It’s been >2 weeks. Any luck?

No, still not got it working. Have given up on it for now.