AR750 - Windows 10 Teams App Killing USB Tethering

I’m experiencing an interesting issue with my AR750. When I open the Teams app, and intermittently if I leave it open, the WAN connection via USB tethering will go down and LuCI shows the following message in the system log:

 kern.err kernel: [  292.027378] ipheth 1-1.2:4.2: ipheth_rcvbulk_callback: urb status: -79

The topology is as follows:
iPhone <-usb-> AR750 <-wifi-> Windows 10 laptop

The AR750 is running stock firmware at version 3.215.

I can bring the WAN back up by restarting the interface in LuCI.

I tested a little bit and I didn’t get disconnected. I didn’t use teams to call though.

Maybe just try another cable, or power adapter.

Ok I made a little bit of progress.

I tried a different power supply, different power cable, and a different iPhone cable. None of those made a difference. The issue remained.

I did try a newer iPhone and could not recreate the issue.

Oh iPhone 12 running iOS 16.1.1 → tethering crash when opening Teams on the laptop.
On iPhone 13 running iOS 16.1.1 → no issues.

Next I will try to factory reset the iPhone 12.

Usutally a reboot of the iphone works. Have you tried?

I have tried rebooting, it doesn’t seem to help.

I’m on a business trip now, I’ll do a full reset of the phone when I get home in a few days. I’ll post here again with the results.