AR750s can't connect to internet

Everything worked fine yesterday. Today the router can’t connect to the internet neither via LAN nor via Wifi. I can connect to the router. Internet gateway is OK. Wifi connection shows up for a few seconds then disappears. Haven’t touched anything in the router’s settings - yesterday it worked fine, today it doesn’t. Is it possible that a hardware malfunction could be causing this? How could I diagnose it? What tests can be performed?

go to the advanced settings > network > diagnostics for ping, nslookup and traceroute commands

poke around the welcome page of the advanced settings for general clues.

go to advanced settings > status > system log / kernel log for logs.

First, show a photo of your connection. Just to make sure connection are correct. e.g. WAN is used to connect to your gateway.

Second, can you still connect to the router, if yes, pls do as @chromebook said and get the log.

Problem solved!

Sorry for the alarm - it turns out it was nothing. I did as @chromebook suggested and immediately noticed the router’s time was off. Since I use Wireguard (I should have started with that!) it depends on the correct time to establish a connection.