AR750S - can't reset, can't debrick

I’ve got an AR750S that was flaking out on me, so I tried flashing it with regular OpenWRT.

Got that to work, then flashed it with the latest RC version (21.02rc4). Seemed like it was working, but apparently OpenWRT needs a big warning on the System>Software>Updates page saying “don’t actually update anything shown here or it will break stuff”. That’s the long version.

The short version is that now, I have a lovely paperweight that looks kind of like an AR750S, that I can’t get any useful response out of.

Yes, I’ve gone thru the OpenWRT ‘factory reset’ procedure, and the GL.inet version - didn’t do a thing. Nothing, nada, zip.

I’ve also gone thru and done the GL.inet ‘debricking’ procedure, multiple times. Yes, I configured the ipv4 networking on my PC the way it’s shown in the procedure. Yes, I only have one network cable connected between the PC and the travel router. Even swapped the network cable out, just in case. The power light is on solid, the 5GHz light blinks five times, then the 2.4 GHz light comes on solid. When I open the browser (any browser, pick one) to there is… nothing. Times out. Can’t find anything to connect to.

Any ideas or suggestions welcome.

Have you check the new uboot video How to Use UBoot to Debrick Your GL.iNet Router 2021 - YouTube

If everything is correct but still time out, may just try a different pc

The video follows the same process as the procedure already linked, so yes.

If you can give a logical reason why changing PCs would make any difference, then maybe.

Did you plug the Ethernet cable from WAN to LAN port after flashing and then entered the IP?

According to the GL.inet debricking procedure, step 2, you can use either port for the debricking. Having gotten bitten by leaving it in the WAN port, I generally just use one of the LAN ports instead. The gotcha generally arises after the firmware has been flashed, and you’re still connected to the WAN port, wondering why you can’t connect to the LAN. I’m not even getting to the firmware re-flash page to begin with.

For the lack of any better option, I tried fiddling around doing the debricking procedure with the cable in the WAN port, then moving it to the LAN port once the lights have finished flashing. No, it didn’t make any difference.

What I did was:
Plug the Ethernet into WAN, set the IP of the computer to and the Router to, also DNS.
Did the uboot, flashed the RC4 Kernel. Changed cable from WAN to LAN, waited a bit and then entered Went to System/Software and upgraded the Sysupgrade for the AR750S previously downloaded from OpenWrt.

Just some key points:

  1. Connect only one cable from the pc to the router. The cable can be plugged to WAN or LAN. But just disconnect other cables.
  2. Do not disconnect, reconnect the cable during the process

If everything is correct but still cannot.

  1. First try other ports. If there are three port just try others. Do not matter wan or lan.

  2. Try other pc. Why this matters? Because some network card has problems in uboot process. No idea which problems but it just happens, although very rare. If you have a network switch, use the switch in the middle. i.e. cable from switch to router, cable from pc to switch. Make sure there is only one cable connected as well.

Okay, this is just weird - and offends about every sense of rationality I can think of.

I’d already tried the other ports. No bueno. The PC (laptop) in question has done the debrick procedure previously, with no problems. Doesn’t make any sense that it would suddenly not work now.

The ‘try another PC’ thing just annoys me on every level. What if someone doesn’t have another PC? But, as it happens, I still had a ‘spare’ Dell 7040 USFF box sitting here that I haven’t gotten around to using for it’s intended purpose (Proxmox cluster), still running Win10.

So I unplugged it’s ethernet cable, reconfigured the IP address for the port, and plugged in the cable from the AR750S. Nothing. Redid the ‘debrick’ procedure, for (at least) the tenth time… and shazaam, the Firmware Update page shows up on the other PC. And of course, that one didn’t have any of the firmwares downloaded to it, because I honestly didn’t expect that to work.

Before I went to all the trouble of moving files between the two computers, I decided to move the network cable back to the original PC (laptop), and try loading the page again. And like magic, there’s the same Firmware Update page, like nothing ever happened, like I haven’t been fighting this for the better part of two days. Maybe it realized it was getting awful close to getting used for target practice @ 300yds?

But wait… .there’s more :roll_eyes:

Went to apply a ‘clean’ version of OpenWRT, downloaded from the GL.inet site, and… nothing. 5 minutes. 10 minutes. No response. Changed cables around, reset the ip settings, etc. etc. etc. all the crap I’ve done before. Nothing. Lights are on, but nobody’s home. Tried reflashing again. Now back to the state of “can’t get the Firmware Update” page to come up on either PC.




Did you also set the DNS on your computer to Did you clear the cache of your browser as well? That’s quite important!

I’m not quite an expert on this but I see the last firmware available for AR750S in OpenWRT web page, is 19.07.8.

but, strange thing, if you have an older AR750 you can install 21.02.0-rc3

OK I didn’t know this. Thanks