AR750S-Ext with USB modem

I am trying to establish a connection for the GL-AR750S-Ext with Verizon USB 551L router and getting no connection

Does anybody tested it before?

Have you tested that the USB modem works on a PC/computer?

What colour is the LED status indicator on the GL-AR750S? Also, check that the kmod-usb-net-qmi-wwan has been installed.

I did test it with Windows with no issue after installing Novatel driver and using VZAccess Manager Software
I see 3 LED on GL-AR750S Power 2G and 5G, all are on.
kmod-usb-net-qmi-wwan is installed

Novatel USB551L (Verizon) is listed as a compatible modem with QMI. Auto Setup and Manual Setup procedures:

Check what is displayed in Manual Setup. Choose QMI and input the correct apn.

I did see this instructions
Auto mode does not work
Tried manual mode as well no luck.

I checked that.
Does not seem it is even trying to connect

If not already done so, then try upgrading to the latest firmware version.

As you are using another modem I dont know exactly how it works. Generally Verizon network needs a process of operation to activate the service.

I can only give some method so that you can try.

First find the device list and see what devices are there, e.g. ttyUSB0, ttyUSB1 …

There is one interface used for data. Need to choose that device

Then set the APN to “VZWADMIN”, and Apply wait a while so that it dials.

  1. Go to more settings, IPV6 and enable IPV6. choose modem_1_1_2 and apply.

  2. Go back to modem settings, choose device cdc-wdm0 and use apn VZWINTERNET an apply.

Just tried to updated to latest version and it did not help

I’ve tried that
I was not able to find modem_1_1_2 in IPV6

however I enabled it and made step 3. still did not help

oh if you use qmi mode it should be wwan.

I did switch it to wwan but no new modem option appeared.

Sorry seems I was wrong.

wwan is for repeater.

Can you just enable ipv6, then edit the config directly /etc/config/network and modify the interface

config interface ‘wan6’
option proto ‘dhcpv6’
option ifname ‘@modem_1_1_2
option disabled ‘0’