Ar750s extender mode only works for a few hours

Hi All, I’m using the ar750s in extender mode as a bridge for a remote IP camera. I have a wired IP camera plugged into the ar750s that bridges to another WiFi access point. I can only keep the connection alive for about an hour and a half if I connect using 2.4GHz. If I connect via 5GHz it seems to keep the connection alive.

I have modified the ar750s to use external SMA connectors for larger antennas. That’s a simple process since the main board of ar750s used u.fl connectors for the current antennas. I just removed those and added u.fl to SMA cables and that worked well for turning the ar750s into a bridge with external antennas.

I’ve tried the following firmware versions with no success at keeping the 2.4GHz connection alive very long:


I need to use 2.4GHz because that’s the frequency of my expensive parabolic antenna. Right now I’m testing the hardware in my house close to the WiFi access point using smaller monopile antennas. I can’t get that connection at 2.4GHz to stay alive. Once it drops I can no longer see the IP cam on my network.

I thought this would be an easy thing to do with the ar750s but I’m seeing that’s not the case.

Any thoughts on how I can get this working on 2.4GHz extender mode?

After you set up repeater, can you disable the repeater manager.

/etc/init.d/gl_health stop
/etc/init.d/gl_health disable

also rename /usr/sbin/gl_heath to another name.

Thank you. I will try that. I appreciate the help!!

Okay, so I tried doing this:

/etc/init.d/gl_health stop
/etc/init.d/gl_health disable
and renaming gl_heath

It still disconnects after about 1-2 hours. Once the connection is dropped it will not reconnect. After the connection is dropped the 2.4G LED is still blinking on the AR750s. I’ve versions 3.100, 3.101, 3.104 and 3.105. All do the same thing. I even ordered another AR750s to test and the same issue. I can’t understand why this product does not work well in Extender mode. I’ve seen a lot of other postings about the same problem.

Any other ideas what I can try? Any help would be welcome.

I have the same issue. Bought this to connect my cameras to, running in extender mode with all WiFi off and cameras work for a couple of hours and then drop off the network. I don’t have a separate SSID for 5G, so I have no say in how it connects to the router. Looks like this is a bug, so will have to return it if there’s no fix. Shame, as works perfectly for a couple of hours!

I filed a bug internally. Now don’t know what is the reason.