AR750S firmware download has no .bin file

Following these instructions (Debrick via Uboot - GL.iNet Docs 3), I need to download a .bin file to get the firmware for my AR750S and then upload it via the U-boot web interface. But GL.iNet download center contains only .img files that cannot be uploaded via U-boot. How do I debrick without a .bin file?

When I look for firmware for the AR750, I see .bin files so this appears to only be an issue for the AR750S.

Thanks in advance.

Please read this manual carefully. To debrick a AR750s via U-boot you have to download the .img firmware file and upload to the NAND flash.

1 Like

My U-boot interface at does not have this option:


How do I upload the .img to the NAND flash?

Yes, you are right, the menu looks a little different, but you dont’t need a bin file. With an img file you can easy debrick your AR570S via U-boot. I have just checked with my Slate. It works. With last firmware 3.105 I had an error, but with 3.100 it was without problems.

1 Like

Sorry I am missing something. Are you saying I should use the U-boot web interface at When I try to upload the .img file I get an error that says it is too large. Can you be specific please what you used to upload the 3.100 .img file to the AR750S device?

I used U-boot to flash a router with an img firmware.
My U-Boot menu on my Slate looks like this.

Try with firmware 3.100. It worked for me. With last firmware 3.105 I had a Problem during flashing.

1 Like

By the way, you can fine a .bin file for the AR750S following this link
This is a last beta firmware. Before you try it please contact technical support from Gl.Inet
I am not sure it is not damage your device:)

Thank you so much 3.100 worked so I am back in business and this particular thread is resolved.

Question: do you know how I can update to OpenWRT 19.07 or later?



1 Like

If you don’t need Gl.Inet interface and you have skills with luci you have to download an OpenWRT firmware for your Slate and install it via U-boot.
At the moment there is no operwrt factory firmware for AR750S for download and I’m not sure
is it possible to do a sysupgrade procedure via luci with sysupgrade.bin

I personally will wait for an updated Gl.Inet Firmware.

That is working for me. I loaded it via the U-Boot menu.