Ar750s: Galaxy S10 crashes when connected, and other issues

Hello everyone! I’m a new user of the ar750s router. It’s an amazing piece of hardware, I really love it. However, I’m having some issues and since I would define myself a basic user, I need some help from you guys.
I updated the device to the latest version 3.104
Let’s go to the problems:

  1. When I connect my galaxy s10 to the router and I turn on the USB tethering, the phone immediately crashes and reboots. I’ve tried with three different S10s, and everyone of them showed the issue.
  2. When I check on “override dns for all clients” and run a scan on the WAN side i see that port 53 is open to the WAN! I’m not an expert as I said, but definitely shouldn’t be like that, am I right? However, this happens only when I choose the override option.
  3. It seems that the 2.4ghz wifi reaches a maximum of 60mbs while the 5ghz reaches higher speeds without problems. Is that normal? 60mbs seems pretty slow.
    Thank you all in advance and sorry if I didn’t use the right terminology.

This is a bug. Under fix.

This is totally normal. If you get 60Mbps on 2.4G that is petty good. 2.4G wifi interfere a lot. Ideally you can get up to 80-90Mbps on 2.4G. 60Mbps is good. 40Mbps is normal.

For Samsung, I really do not know why!!!

Thank you for the reply Alzhao.

Sounds great!

I saw that in the release notes of the last firmware version says that the issues for the galaxy s10 were resolved. I also tried to revert the firmware, but nothing worked.

Today I tried to use the repeater mode but I couldn`t connect to my home 5g wifi, the name was greyed and a small dfs icon appeared on the side.

The router does not support DFS channel because of certification. Can you use other channel on your main router e.g. 36, 40, 44, 48, 149, 153 etc.

Thank you for the reply Alzhao.
I have another question, I activated smb2 protocol from ssh as the guide on Gl.iNet website says and file sharing works well with Android. However, Windows does not allow guest access. So, I tried to change the settings again via Putty ssh according to this guide that i found here in the forum :

The problem is that when i try to prompt /etc/samba/smb.conf.template it tells that I don’t have the permissions to access. Actually even if I put only /etc the situation is the same.
is that normal? how can i manage to connect windows without changing lanman settings in Local Security Policy.
Thank you!!

By default you cannot change files on the router via SAMBA.

You can just use winscp to do that. SSH to the Router - GL.iNet Docs

I’ve managed to create a password for the “nobody” as the guide suggested.


However, when i map the drive, together with the Sd card i see also this folder.
is it normal?

Thank you!!

1 Like