AR750S - Internet works but error "No internet connection"


#1

I have my device in router mode, wired connection to existing LAN using LAN port (not WAN). I can connect to the internet fine on a device connected to the AR750S wireless, however there’s a constant error message in the web interface “No Internet Connection! Find new networks to reconnect.”, and when I try to connect to Open VPN I get a popup “Warning: No internet” and it won’t connect.

For reference, when I connect via the WAN port it all works fine (as long as I set custom DNS settings).


#2

Did you connect the main router’s LAN to AR750S’s LAN port? If you did, it’s a wrong connection. You should connect to WAN.

If you don’t set custom DNS, does it work?


#3

That’s what I’m doing. If I connect to the WAN port, devices connected to the AR750S can’t see anything else on the network such as my NAS.

No, no internet connection at all.


#4

I am confused, if the AR750S is working on router mode, I think it can’t work if you attach the main router’s LAN to AR750S’s LAN.

Could you ssh to the router, execute those commands and show me the output.

cat /etc/config/network
ifconfig
logread

#5

Thanks for your help. I’ve just masked anything resembling a MAC address. My goal is to set it up so I can use this router for VPN connections but still have access via it to other devices on the network.

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config globals ‘globals’
option ula_prefix ‘xx:xx:xx:xx:xx:xx::/48’

config interface ‘lan’
option type ‘bridge’
option proto ‘static’
option netmask ‘255.255.255.0’
option ip6assign ‘60’
option hostname ‘GL-AR750S-248’
option ipaddr ‘192.168.0.27’
option ifname ‘eth0.1’

config interface ‘wan’
option hostname ‘GL-AR750S-248’
option metric ‘10’
option ifname ‘eth0.2’
option proto ‘dhcp’
option peerdns ‘1’

config interface ‘wan6’
option proto ‘dhcpv6’
option ifname ‘eth0.2’

config switch
option name ‘switch0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘switch0’
option vlan ‘1’
option ports ‘2 3 0t’

config switch_vlan
option device ‘switch0’
option vlan ‘2’
option ports ‘1 0t’

br-lan Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr:192.168.0.27 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: xx:xx:xx:xx:xx:xx:9248/64 Scope:Link
inet6 addr: xx:xx:xx:xx:xx:xx::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:23004 errors:0 dropped:0 overruns:0 frame:0
TX packets:15292 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:4345755 (4.1 MiB) TX bytes:6932993 (6.6 MiB)

eth0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet6 addr: xx:xx:xx:xx:xx:xx:9248/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30416 errors:0 dropped:0 overruns:0 frame:0
TX packets:17975 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21806267 (20.7 MiB) TX bytes:3599855 (3.4 MiB)
Interrupt:4

eth0.1 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30390 errors:0 dropped:0 overruns:0 frame:0
TX packets:16956 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21250913 (20.2 MiB) TX bytes:3190289 (3.0 MiB)

eth0.2 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet6 addr: xx:xx:xx:xx:xx:xx:9248/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:1005 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:336306 (328.4 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:591 errors:0 dropped:0 overruns:0 frame:0
TX packets:591 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:45768 (44.6 KiB) TX bytes:45768 (44.6 KiB)

wlan0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet6 addr: xx:xx:xx:xx:xx:xx:9249/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:29230 errors:0 dropped:0 overruns:0 frame:0
TX packets:45288 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6051024 (5.7 MiB) TX bytes:29607366 (28.2 MiB)

wlan1 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet6 addr: xx:xx:xx:xx:xx:xx:9248/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:9023 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:1686280 (1.6 MiB)

This is very long, should I really post it?


#6

Could you connect the main router’s LAN to AR750S’s WAN, execute those command again.

ifconfig
mwan3 status  

If the logread is too long, you can zip it and upload to here.