AR750S no network in uboot

i tried to boot into recovery, but it does not seem to have network connection.
i attached a laptop with static ip to external port
i then attached a serial console cable this is the output:

U-Boot 1.1.4-ga35cd45d-dirty (Jun 22 2018 - 12:48:24)

ar750s - Dragonfly 1.0DRAM:
ath_ddr_initial_config(278): (ddr2 init)
ath_sys_frequency: cpu 775 ddr 650 ahb 258
Tap values = (0xe, 0xe, 0xe, 0xe)
128 MB
Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
flash size 16MB, sector count = 256
Power up PLL with outdiv = 0 then switch to 3
No valid address in Flash. Using fixed address
ath_gmac_enet_initialize: reset mask:c02200
athr_mgmt_init ::done
Dragonfly ----> S17 PHY *
athrs17_reg_init: complete
SGMII in forced mode
athr_gmac_sgmii_setup SGMII done
: cfg1 0x80000000 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
Qualcomm Atheros SPI NAND Driver, Version 0.1 (c) 2014 Qualcomm Atheros Inc.
====== NAND Parameters ======
sc = 0x87ff6230 page = 0x800 block = 0x20000
Setting 0x181162c0 to 0x4b962100
Press reset button for at least:

  • 5 sec. to run web failsafe mode
    Reset button is pressed for: 5

Button was pressed for 5 sec…
HTTP server is starting for firmware update…

Trying eth0
dup 1 speed 1000
HTTP server is starting at IP:
HTTP server is ready!

ARP Retry count exceeded; starting again
Trying eth0

ARP Retry count exceeded; starting again
Trying eth0

any ideas how to fix this?

What operating system do you use?

Do you have a try to access on browser?

It’s a macbook air runnin mojave.

Yes i tried accessing it via webbrowser too. no success.
I tried all 3 ethernet ports. and i can ping (and access the webinterface) a mt300a using the exact same setup.

For some reason, uboot web UI doesn’t work with my Linux, but works with windows.

Can you try windows?

i can, i did, it does not change anything.

i’m pretty sure its not a problem on my environment but on the device.

I know it is the uboot itself. But for some reason it works with windows without problem. I have feedback from others and it is the same.

Not sure what is wrong, still debugging this problem.

well i guess you can add “windows 10 in virtualbox with bridged usb network adapter” to your list of not working configurations.

today i tried it on a physical windows 10 install, working as it should.

It is about the physical Ethernet card, so virtual machine doesn’t work.