AR750S unable to get ipv6 address when using wireless client mode

When I create a new interface using’‘dhcpv6’’ as I often do on other openwrt routers, it doesn’t get the ipv6 address. When I restart the router, the interface “wwan6” becomes “unsupported protocol type” and asks me “install protocol extension” even though I have installed “luci-proto-ipv6” and “luci-proto-ppp"

When I set the interface “wwan” to dhcpv6 client mode, it seems to be able to correctly get a “scope:global” ipv6 address, but it can’t ping to the address that should be connected, or even connect to the previous level gateway address. When I restarted the router and it automatically connected to the WiFi that should be relayed, wwan changed back to “dhcp client” mode instead of the dhcpv6 client I set.

I have achieved my desired goals on other native openwrt routers, but I have encountered setbacks on the AR750S. I am looking forward to knowing the reasons for this and I sincerely thank those who can help me solve this problem.

May I have a look at your network configuration?
/etc/config/wireless and /etc/config/network

1 Like

Of course!

Cause I only want a ipv6 connection, so I just turn wwan to a dhcpv6 client

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option doth '0'
        option txpower '20'
        option txpower_max '20'
        option band '5G'
        option disabled '0'
        option org_htmode 'VHT80'
        option channel '161'
        option htmode 'VHT80'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'GL-AR750S-386-5G'
        option encryption 'psk2'
        option key 'goodlife'
        option ifname 'wlan0'
        option wds '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca956x_wmac'
        option txpower_max '20'
        option noscan '1'
        option htmode 'HT40'
        option band '2G'
        option disabled '0'
        option country 'US'
        option legacy_rates '1'
        option channel '6'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'GL-AR750S-386'
        option encryption 'psk2'
        option key 'goodlife'
        option wds '1'
        option ifname 'wlan1'

config wifi-iface 'guest5g'
        option device 'radio0'
        option network 'guest'
        option mode 'ap'
        option wds '1'
        option ssid 'GL-AR750S-386-Guest-5G'
        option encryption 'psk2'
        option key 'goodlife'
        option ifname 'wlan2'
        option disabled '1'
        option guest '1'

config wifi-iface 'guest2g'
        option device 'radio1'
        option network 'guest'
        option mode 'ap'
        option wds '1'
        option ssid 'GL-AR750S-386-Guest'
        option encryption 'psk2'
        option key 'goodlife'
        option ifname 'wlan3'
        option disabled '1'
        option guest '1'

config wifi-iface 'sta'
        option network 'wwan'
        option mode 'sta'
        option ifname 'wlan-sta'
        option ssid 'bjut_wifi'
        option bssid '94:28:2E:F1:67:70'
        option channel '6'
        option device 'radio1'
        option encryption 'none'
        option disabled '0'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option hostname 'GL-AR750S-386'
        option ipaddr '192.168.8.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option hostname 'GL-AR750S-386'
        option metric '10'
        option peerdns '1'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 0t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'guest'
        option ifname 'guest'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.9.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wwan'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'

I can get an address like this

but I can’t connect to the address which I can on PC

on router:

1566882164039.png

on PC:

I adjust my config files base on your sample, but still can’t successfully ping through any address. Anyway, thank you very much for your effort.