AR750S Wireguard keep alive

for some reason all wireguard configurations get keep alive 25 seconds by default.
But when I clear this value by deleting and saving, it reappears automatically.

From my understanding this is only neccesary when running a server behind a firewall.
I want to be able to remove this bc it consumes data unneccesary in my case .


Yeah! It will send keep alive package every 25 seconds by default. Is can’t configuration

I think the packet is too little to ignore.

It isn’t configured at present.

what is the reason to enforce this keep alive ?

I run wireguard on android and several ubuntu boxes without this and it works fine without keep alive.

I really think it should be up to the user to decide on this.

For WireGuard client, you can disable keep alive by set it to 0 on configuration.

ok, set it to 0 seems to work. Good that it can be turned off.

It is not very clear from the user interface though, I deleted the value in the web page and it kept coming back as 25s.

Also, If you can explain why you set this as default, normally it would not be needed?

WireGuard tries to be as silent as possible when not being used, if the client or server is running behind a firewall, it can’t communicate with each other. Both of server and client may running behind a firewall.

So we set it to 25 seconds by default.

As you said, it is not clear from ui. Do you have any great advice?

I’m running wg client from work network (via FW/NAT) to my home server, works fine without this setting.
From my understanding it is only needed if the server needs to initiate communication with the client, but I’m no expert on wg.

as for the user interface it would at least be an improvement if an blank value is interpreted as 0 and turn off this feature.