Aria2 and Aria2 web-ui

Hi, I’ve got a MT300A.

I tried to install Aria2 but I got an error message. I also tried to install Transmission and I got an error too. [see screenshot]

I’m a bit confused. I’d like to know how to install Aria2 and its web-ui, and how to automatically open it at router’s startup.

Can give me some help? Does I have to execute some commands through ssh?

You can omit these errors and continue.

How can I continue? I can’t get Aria2 working. Could you guide me?

I have installed Aria2 WebUI and also Transmission Web, but I can’t reach their web-ui interfaces. I tried 192.168.1.1:9091 and 192.168.8.1:9091 for Transmission; 192.168.1.1/Aria2 and 192.168.8.1/Aria2 for Aria2. In both, I can’t reach the web-ui.

Could it be due to the default subnet of the gl.inet router which is 192.168.8.1, while Aria2 and Transmission ask for a 192.168.1.1 by default?

PS: I followed this guide for Aria2 and it doesn’t work https://www.youtube.com/watch?v=LNLMV1SCULc

I got this. I think the problem could be here.

Any help?

ok, I don’t know how, but I managed to solve this issue.

Now Aria2 and Transmission webui work for me.

Actually the port is used because you have already started on process. You need to kill the old process to release the port.

I think you rebooted and it works.

How to make aria2 web ui work? Please i had same problem, i can’t access web ui aria.

thx

If you haven’t already set it up, see this https://www.youtube.com/watch?v=LNLMV1SCULc

 

When you have done everything, you can go to the web UI here:

http://192.168.8.1/aria2/index.html

 

Every other tutorial say to go to http://192.168.8.1/aria2/, but on our router it doesn’t work.

Hope this can help.

Anybody worked out how to get aria working, I’ve installed it ok through the plugins section and rebooted my GL iNet 300M but I can’t access it using any of these:

http://192.168.8.1/aria2/index.html - Takes me to the GL iNet Admin page
http://192.168.8.1/aria2/ - Takes me to the GL iNet Admin page

I followed the video in tipo0011’s post and at 4.51 I see that aria is listed in the startup items, I don’t see it listed my startup items…so does anybody know how to get it listed here?

I now have aria listed in my startup items, I didn’t realise there are two plugins. You need to install both aria2 and webui-aria2 plugins.

Still can’t get to aria2 via the links though…

Worked it out, the link that works is http://192.168.8.1/webui-aria2/index.html

Next problem I had when logging into the webui-aria2 interface I kept getting the following error

Oh Snap! Could not connect to the aria2 RPC server. Will retry in 10 secs. You might want to check the connection settings by going to Settings > Connection Settings

I solved it by first formatting a USB stick as exFAT, naming the stick USBexFAT64G and inserting into the USB port on my GL iNet 300M

Then going back into the router config, going to More Settings > Advanced > then loggging in.

Once in the Advanced config, go to System > Startup

Go to the very bottom of the page called Local Startup, place the cursor on the line above where it says it exit 0

Then paste the following:

aria2c --enable-rpc --rpc-listen-all --allow-overwrite=true --auto-file-renaming=false --continue=true --dir=/mnt/USBexFAT64G/download --max-connection-per-server=4 --max-concurrent-downloads=1 --max-resume-failure-tries=10 --daemon

Click submit and reboot the router.