Assign static IP to Wireguard server behind main router

I have set up the Beryl as wireguard server behind my main home router. I would like to my main router to assign a static IP to the Beryl so port forwarding can always be correct and also in the future I can be sure to connect to this server from external network without issues. How can I do that? Thanks

The DHCP server on your main home router should have a feature to reserve and assign a static IP address to the MAC address of the Beryl router’s WAN port, which is quite common.

If your main home router does not have such a feature, then you can assign a static IP address directly on the Beryl router via LuCI UI → Interfaces → WAN → Edit → General Settings and set Protocol = Static address.

I do not work for and I do not have formal association with GL.iNet

Thank you so much @wcs2228 for your prompt response. Per your suggestions I was able to 1/ reserved a static ip for the Beryl on LAN and 2/ enabled DDNS on it and replaced that in place of an IP in the endpoint for my wireguard client config which also works

I will be travelling overseas with the Slate router and really need this to connect back home so I can do my work as normal. Is there anything else you would recommend for the whole setup to work as expected? Thanks

1 Like

A day or so before you leave, I suggest you reboot the main home router and the Beryl, then check again that everything works properly. All my network equipment are on UPS in case of power failure.

Don’t forget to bring laptop charger, router adapter, USB chargers, USB cables, travel plug converters, etc. I keep all of those items in a kit bag ready for travelling.

I do not work for and I do not have formal association with GL.iNet