Assigning IP address via DHCP to printer

GL-AR750S rotuer and HP printer.

The router: The printer (hp printer) is plugged in the rj45 lan section of the router.

The printer is set to DHCP.

I have set:

  • Admin panel > lan ip > to (for the computers) and:
  • Admin panel > lan ip > static ip > mac: 38:ea:a7:09:9e:9E (of the hp printer) ==> ip:

When I turn on the printer and print the self test. The ip address is: and only 2 packets sent.

What am I missing?



i would double check that the mac id is correct and that nothing else is using
i have seen that with printers over the years. that the ip address is

not sure if this matters, i think that the gl-inet uses 192.168.8.x for vpn ip addresses.

when i am dealing with a small lan, and need to reserve an ip address for a device.
in addition to setting a static ip address reservation in the router, i also hard code that address in the printer.
if the routers die or something happens to the config over the weekend, the local lan users will still be able to print to the printer.

Solved. It’s working now.

The problem is either a bug or the documentation.

For these things to work with my router. The router needed to reboot. After that, it worked. I thought that the apply button on the web interface was enough… Must have been the similar problem with my resetting for factory default not working properly…

Thank you

glad you got it working.

tho next time, i would try to reboot the printer, then, if need, be the router.

The printer was rebooted multiple times. It uses the DHCP to assign the IP address only at startup.