Automatically select another config file


I have a GL Ar300m connected to NordVPN servers via openvpn.

Sometimes, I am just disconnected from the VPN. I guess the issue come from NordVPN (server overload or something else).

Is there a possibility to ask to the router to automatically try another server if one is not working ?

I guess that it could be possible with a script or something but I have really no knowledge in this field.

Do you have a script “ready to use” by chance?

Thank you very much !

Hopefully problem is being investigated:

Yes, I just saw it.

I quickly searched on Google but I did not find these topics. My bad.

I lost again my connection today so I spoke with the NordVPN Team.

They asked me to send the log and to :

  • Change the DNS in order to use the NordVPN DNS (previously I used the DNS of Google)

  • Download any UDP configuration file, open it with any text editor and then remove the following line:explicit-exit-notify 3 because Gl firmware doesn’t understand that line therefore causes the issue with UDP configurations.

So I will test this to see if I can keep my connection now.

>>> remove the following line: explicit-exit-notify 3

Hmmmm, but Nord Ovpn files don’t have that line it!

And I can’t see the DNS servers being the issue but I look forward to the conclusions of your testing.

You have this line only in the UDP files if I understood properly :slight_smile:

Honestly, I am not very confident but we will see.

As I siad, none of the ovpn files (UDP and TCP) have that line in it.

Unfortunately we can not upload this kind of file.

So I invite you to check the following files as examples : and

Ahhh, interesting! I checked the files already in my router and none of those have the “explicit” line. However, I just checked the zip file I have on my PC and they do indeed have it!
So, at some stage Nord must have updated the files, as I downloaded a new copy after setting up my router…unless this line is somehow removed in the upload process (which I doubt).
Bottom line is none of my ovpn files have the line and I still lose connection.
Also, I believe this line is only included in the UDP files but I also get disconnects using TCP.

Too bad, we still not have our solution.

As soon as I lose my connection I will reach the NordVPN team again and send my log.

What did they say when you explained our problem ?

Update here: 404 Page not found - GL.iNet

Thank you Glitch :slight_smile:

The NordVPN team told me to add the line : “auth-retry nointeract” and for the moment it is working :slight_smile:

Thanks for the input.