Ax-1800 Flint - some sites don't load or take too much time to load

I bought a new Flint 3 days ago.
It came with firmware 4.1 rel6 out of the box. Some sites like Amazon site don’t load or take too much time to load
How to fix that issue?
I start to have a deception in this router.
I had this issue yesterday, I changed the wifi ssid name and it worked. But the issue comes back again today.
Anyway to make this router works before I return it?

Update: I updated to the last firmware 4.2 snapshot and the same issue persist.
Amazon site and some other sites don’t open!!!
No vpn ! Tried opendns and Google dns and disabled Adguard. Still the same sites don’t work.
Power off and on, still the same sites don’t open on all my devices

Do you have a VPN open?
in case, do you have another router at home, if Yes, can you try if the same site are reachable with that other router.

I returned back to the stable 4.1 rel 6
Factory reset
Everything works normal
Added Vpn client
Added Vpn policy based on the client device
Still everything works normal.

I turned ON Adguard: issue start: Many sites (Amazon included) takes soooo long time to open on computer not routed through VPN.
I added rules in Adguad to accept Amazon but the issue persists.
I disabled adguard. The issue continue to persist.
I rebooted. The issue continue to persist.
I disabled the VPN - things are back to normal

There seem to be an issue when using vpn client + vpn policy based on client device + Adguard

Any ideas how to workaround?

Do you setup manual DNS on your PC? I’ll test this issue tomorrow.