AX-1800 Flint tethering

Has anyone successfully USB tethered a Moto G 5G plus (UK o2 network) to the AX-1800 Flint.
When i try the Flint does not recognize my phone is attached.
I really wanted to tether my phone to the Flint but running out of things to try, have reset network on the phone, enabled de-bugging, changed cables, wifes Samsung also on o2 is picked up by the Flint immediately.
Having searched the net it appears the fault lies with the phone, other having problems tethering the Moto G 5G.
I should say it tethers ok with my Win 10 laptop.
Any suggestions appreciated.

Can you post system log when you plug in your phone to the router?

I am missing ‘say phone to tether’. Plug US in the phone, open the drop-down menu (slide the finger from very top down). There is something with ‘USB charging, click for more’. There are different options ‘Charging, Filetransfer, MTP, PTP, … , Tethering’.

If this option won’t appear when connected to the Flint, does it appear while connected to a PC/Laptop/Notebook/…? Read your text twice. Maybe my first suggestion is not relevant, too …

LupusE, i know how to tether the phone the problem is the Flint fails to see its connected.
thanks anyway.

What is the Android version on your Moto G G5? Ethernet Tethering came out in Android 11. if so, is it enabled it in Settings → Connections?

I do not work for and I am not directly associated with GL.iNet

Phone is running Android 11, to-date tried several cables, de-bugging mode and safe mode on phone, tried my wifes Samsung which works and is recognized right away, i sent support the logs and they have said the phone does connect but immediatly disconnects.
Guess i could try restoring the phone to factory settings but thats for the future, no time to do this right now, currently the phone / Flint work fine in repeater / wifi configuration.

Maybe just reboot the phone. I use iphone and when I have problem in tethering, a reboot solves.

alzhao, tried reboot phone, tried phone in safe mode etc etc, will play with it later, other things to do right now, but thanks for the suggestion

When you go into admin under connections if the USB is plugged into flint and phone there should be a button that says “usb0” CONNECT click it,

On your phone Open Developer Mode change
–usb option to tethering (as primary option).
–make sure USB hardware acceleration is on

restart phone
unplug and plug usb into phone and flint.

Hi, thanks, yes i know what there should be “usb0” but there is not.

As a test, can you try Ethernet tethering the Moto G 5G to an USB port on a PC (not Mac)? If it works, then the problem is not with the smartphone.

Hi, not sure how to to do that, as far as i am aware its not posible to connect moto g 5g usb to an ethernet port.

Sorry, I have mixed up USB tethering and Ethernet tethering.

Since you said the Moto G 5G tethers ok with your Win 10 laptop via USB tethering, this sounds like it is not entirely an issue with with the smartphone.

On the other hand, Ethernet tethering is a new feature that came out with Android 11, which allows you to plug a USB-C Ethernet adapter ($15-$20) into your smartphone, then connect an Ethernet cable from the adapter to the router’s WAN port, just like an wireline ISP modem/router. Because it is standard Ethernet, there should not be compatibility problems with the router.

If you reach a dead end with USB tethering, this may be a good option, but first confirm that Moto G 5G supports the “Ethernet tethering” option in Settings → Connections → Mobile Hotspot and Tethering.

Hi, thanks for that, will look into this adapter, for info the Moto G 6G does have ethernet in the hotspot and tethering settings.
I had a quick look this morning and found the below article, this sounds very promising, thanks again.

https://www.ispreview.co.uk/talk/threads/android-11-ethernet-tethering-working-perfect-recommend-cheaper-5g-phone.37571/

This sounds like in developer mode there is a USB setting that is not set. As stated in my previous post.

Backup phone contacts, passwords, whatsapp etc do a factory reset.