AX-1800 Flint WIREGUARD problems

I bought this router with the notion that it was fast when it came to VPN Wireguard. I have 1Gb/500mbs fibre line. When connecting the VPN of the router to the server in my country (Thailand), I cant get anything over 100Mbs download speed. If I use surfshark directly on my PC, laptop or S22 ultra I get speeds in the 500mbs down and similar up. But on the router its sup par. Anyone else experiencing slow speeds? My friend has the AX-1800 Flint but he says he has a version 2 and he get 500mbs to the Thailand server… VERSION 2? Any help would be appreciated.

Not sure what Version 2 is (do they mean the GL-AXT1800 Slate AX, Chips are the same) . Firmware is 3.x or the newer 4.x.
Are you using a wired or wireless connection?

Perhaps try a different server, I know for me it took a couple of tries to find a server that met my needs.

Sense you metioned you used Surfshark app on the computer check you DNS and network adapter settings you could be doing

Also if you have other devices connected, if the VPN tunnel is pulling 400Mbps that is divided amongst the ethernet ports and wireless adapters.

You can try messing with the MTU size. This has the potential to make it even slower or unstable.

I have tried firmware 3 and now on 4.2.1. My friend has the same router, similar specced computer, connecting to the same surfshark wireguard server in Thailand, same firmware, same config, he gets 400mbs download, I get less about 80mbs. My phone, laptop, and PC all connect with the surfshark app using the same DNS and download at over 400mbs. I tried changing the MTU, made no difference. Do I have a bad router?