AX1800 - trouble connecting to DFS WiFi

Hi there, I have been using Flint for about six weeks now without major hiccups. However, I just moved for work and now have to connect Flint to a 5GHz DFS network (I have noticed it using channels 60 and several ones within the 112-140 range so far).

On the admin scanning page this option is greyed out and I also cannot edit this via luci. I checked the forum extensively and found a few suggested workarounds, but they all involve other routers and have not worked for (my) Flint, currently running 3.207. Most suggestions involved editing the /config/wireless settings but no playing around with channels, countries (Germany here) or providing the relevant mac address has had any lasting positive effect. I managed to connect to the WiFi twice when it was on Channel 60 by manually setting it in the config, but then lost the connection in the minutes/hours afterwards when the router switched to a three-digit channel again.

Can anyone please point me to a Flint-specific solution on how it can automatically connect to DFS networks that change their channels in the above mentioned ranges frequently? Thank you!

option 1:
setup wireless by uci for example:

uci set wireless.sta=wifi-iface
uci set wireless.sta.device='wifi0'
uci set'wwan'
uci set wireless.sta.mode='sta'
uci set wireless.sta.ifname='wlan-sta0'
uci set wireless.sta.ssid='_GL-S1300-549-5G'
uci set wireless.sta.encryption='psk2'
uci set wireless.sta.key='goodlife'
uci set wireless.sta.disabled='0'
uci commit wireless

option 2:
Repeater - Scan - Other…(SSID list)
then manully input ssid, Wi-Fi Security, etc.
On the other hand, disable “Auto scan and re-connect” at Repeater Options

1 Like