AXT1800 file system is read-only

Hi again / there’s a new update available for Tailscale – is there any way you can update your script to take advantage of this?

When I run the current script, it returns: “ Read-only file system”

Any ideas?

The script is dynamic, it will always use the newest available version.

I ran it on my Flint2:

Script finished successfully. The new tailscale version (software, daemon) is:
  tailscale commit: b36943c9b3cfc9f917b202025bfde002b076fc87
  other commit: 99e84774ba7d892c022e79a304b5a365a106ff69
  go version: go1.22.0

Not sure what this means, what are the commands you used?

Here is what it looks like:

Use cd /tmp before. This should fix it.

It tries to update to tailscale_1.60.0_arm.tgz, but can’t…

Your filesystem is read only, can’t tell you why. Maybe some misconfiguration or some other issues.
Maybe running out of space, not sure.

it’s new / no configuration other than turning on Tailscale… If you can think of any way to change the ReadOnly status, I’d appreciate it.

Unfortunately I don’t have a clue.

Thank You!!
Thx for your input.

You need to run umount to make it writable:

service umount start

If the above command fails, run:

mount -no remount,rw /

“service umount start” does nothing / no response…
"mount -no remount,rw / " does nothing / no response

"mount -no remount,rw "
returns the output below:

FWIW, neither can I “firstboot” or even do a 10 second reset from the side button… I may have to just return this one and start fresh with another model?

No output means it worked ! Did you try your tail scale script afterward?

I’m afraid this doesn’t work for me, either… I’ve tried a few times after using your code, and each time get the same result:

It should work fine! Right after executing the following command, run the update script:

mount -no remount,rw /

I tried it on my AXT1800 right now and it worked perfectly.

Could you please reboot your router and do df -h?

Maybe just reset the firmware once.
Then check if your storage is normal.

At last, using uboot to flash firmware once will fix the system.

thanks to all of you / i’m away from work until next week / I’ll try when I get back - I appreciate your input (but using UBoot will be my next move) Until next week - Thank You!!

What about using glinet .bin file with LuCi ? Is it compatible?

Yes. That could work as well.

I had requested on the forum the latest uboot for spitz 3000 . But haven’t gotten any reply from GL staff!

Can you please share the latest uboot file with us?