AXT1800 (Slate AX) - Network Sharing, Drag and Drop Failures


GL.iNET newbie here. I have completed intallation of my new ATX1800 over the last couple of weeks. Great success with everything so far, it’s an excellent device for my home network.

Today I attached a 32 GB USB drive to the router and set up SAMBA sharing to one User with writable access. My workstation is Windows 11, I have mapped the storage as a Network Location. All looking good at first. I have been able to create folders, create new documents, modify and delete them. I can drag and drop folders and some document types from my workstation onto the storage device with no problems.

Unfortunately I am not able to drag and drop .PDF, image or video files to the storage device. Strangely, I can drag and drop a MS Word document but not an MS Excel workbook. Simple text documents are just fine.

For those file types that fail I am receiving a message “Could not find this item…This is no longer located in ”. Holding the Ctrl key whilst dragging and dropping, to Copy the item to the mapped drive, gives the same failure.

I have enabled SMB 1.0 on my Windows workstation but this does not make any difference, so I have disabled it again.

Through the OpenWRT LuCI web GUI I can see permissions for the SAMBA share are Create mask: 0666 and Directory mask: 0777.

Any ideas as to what I am missing?



What firmware version are you using? I have just tried drag and drop and Ctrl+C/V on version 4.2 with Windows 11 and they both work fine.
Have you tried it on other client devices?


The Admin GUI / System / Upgrade / Online Upgrade page tells me my firmware is up to date. Firmware is 4.1.0 Release7. The GL.iNET Download Centre shows this is the current stable version. Firmware 4.2 is a snapshot and is marked “it’s not stable, using on your own risk”.

Similar failure is observed using my iPhone X running iOS 16.3 using the Apple ‘Files’ app. Although I have not tesed exhaustively I am unable to copy/paste either a .PDF or an image file.

We will attempt to reproduce this bug, but it will require a new firmware release to fix. If you don’t want to try beta firmware, you may want to try using another protocol until the release firmware is available.

How long until 4.2 is released as stable? How un-stable is it right now? I may be prepared to risk 4.2 if I know what to expect. Otherwise I shall wait until the bug is fixed in some future release.

Thanks for your guidance and propmt attention.

It is not more buggy than the stable and beta firmwares to be honest with you. I would go as far as to say probably even more stable than a lot of their stable releases at times.

1 Like