AXT1800 x2 chain - issue

I upgraded my two GL-MV1000 which worked great they where setup like this

ISP → TO GL-MV1000 WAN port - > GL-MV1000(1ST) WIREGUARD to lan port → TO GL-MV1000(2nd) WAN port - > GL-MV1000(2nd) WIREGUARD to lan port → PC

That worked fine as two chained wireguard vpns

The same setup on AXT1800 does not work, the wireguad connects on both but internet fails some sites do load a little. One vpn works fine but both on does not.

I have upgraded too firmware 4.1 same result, what setting am I forgetting?

which wireguard service are you using? on both routers.

I could do a try.

IVPN and OVPN tried it OVPN first and IVPN second and the other way around. I will try other services too see

Here is my setup:

  • Main router to ISP modem
  • AX1800 repeater to Main router
  • AXT1800 cable to AX1800
  • My pc cable to AXT1800

ON AX1800 I am using Azirevpn

On AXT1800 I am using Proton

I can do speedtest and access various website

The setup is not ideal for general use becasue too complicated but seems it works.

What I could think of is that you try change the mtu for two wireguard.
The upstream one set a mtu e.g. 1380
The downstream one set a mtu e.g. 1340