AXT1800's 5GHz SSID disappears as soon as device is repeating another 5GHz signal

Is this an expected behaviour or a known bug?

This is an expected behaviour.
When “Repeater” tries to connect to a hotspot, Wi-Fi on the same band had to be temporarily turned off.
Once connected successfully, the Wi-Fi will be restore to on.

Thanks but it never restored itself. I tried multiple times. I suspected that this could be due to the 5GHz being used completely by the forehaul but the same is not happening with the 2.4GHz SSID which has been working normally. I suspect it is a bug.

Did “Repeater” connect successfully? Or does it show “Connecting…” ?
A known bug in beta8 is that “Repeater” will completely use Wi-Fi when it retry to reconnect until the user manually disable it.

If this happens when the “Repeater” is connected successfully, can you provide logs?

It should display after connecting successfully.

That is really bizarre as I have tried it again and the repeater is connected successfully. I have been waiting for more than 30 minutes now and the AXT’s 5GHz is not showing up when scanning on any of my WiFi clients (PC, mobile…etc.). Does it make a difference if I am repeating a DFS channel? I will try a non-DFS one and report back (I love the “Allow Repeat DFS Channels” feature by the way).

DFS may matters. Can you please try more and report back?

1 Like

Quick update. There is definitely a bug here. Repeating a non-DFS 5GHz channel fixes that part of the problem in that the AXT’s 5GHz reappears after a successful connection. This is very reproducible. Repeat a DFS channel = No 5GHz SSID broadcast from the GL.iNet. Repeat a non-DFS channel and the SSID reappears.

The remaining problem is that even when repeating a non-DFS 5GHz channel and the router’s SSID showing up normally, connecting to the AXT’s SSID has no internet connection and the repeater sign is actually in WHITE and not green as it normally should be.

In essence two problems here which could well be related. 1) 5GHz disappears when repeating a DFS signal and 2) when both backhaul and forehaul are using the 5GHz tunnel, the internet drops and web is inaccessible for me.

I may be having the same issue on two of my AXT-1800 units. As soon as I enable Repeater mode on my 5GHz home network, both 2.4GHz and 5GHz SSIDs from my Slate units disappear. The unit continues to flash blue, but I cannot see any of the SSIDs, forcing me to manually reset the units to gain access to the portal again.

My Beryl (MT1300) has zero issues with repeating on either band on the same home network.

1 Like

I’ve also had issues with something similar - AP SSID never shows up when connecting to a 5GHz network as client, but can login if connected to LAN via ethernet. Could be a 40 or 80MHz thing? I feel like this got worse in 4.0.2, but I could be wrong. Issue does not appear to happen in stock OpenWRT built with gl-infra-builder.

1 Like

Upgrading the firmware to 4.0.3 has fixed my issue! You can go to the GLi Download Center to find it.

I was experiencing the issue on 4.0.3, but it seems fine on the custom firmware I built. Who knows