B1300 problems working in with mesh


#1

I was running a small WIFI network with a B1300 and a few repeaters around the place (AR-300M’s), having multiple SSIDs was giving some of the clients trouble so I got two more B1300 and thought I would run a MESH network.

It has only been going for a week and has been nothing but trouble.

The mesh never recovers after a power failure, weather it is a complete blackout or just the master that looses power, sometimes times it’s one slave, often it’s both that need repairing. I’ve got one slave that has been slow blinking it’s mesh led, which I think means it is healing the mesh, it has been doing this for two days since the last time I power cycled the master. Is there any way to get the mesh to recover better?

Also, occasionally the WIFI network goes dead, it is still up, clients can still join, they just can’t get through the router to the LAN network, the only solution to this is power cycle the master.

The WIFI coverage is lousy, it is much much worse than when it was just one B1300. I’m not sure how that is achieved. My Iphone prefers to log onto my neighbors network rather that the B1300 that is sharing the desktop with it, it’s as if the master B1300 has decided to cut down the power or something. It use to work fine on 5G when it was one B1300, but now there are 3 in a mesh the coverage has gotten a lot worse.

Tonights problem is that the master isn’t talking to anything, the WIFI network is still working and WIFI clients can get to the internet, but I can’t WEB or SSH to the router any more, I guess it needs another power cycle.

I tried putting all nodes within 6 meters of each other, line of sight, no obstetrical, and still some clients in the same room still can’t see the network.

Has the Mesh network code been debugged yet? Is it still in Alpha? What is the best way to debug anything? It doesn’t seem to be putting anything useful in the log on the master and I have no idea how to talk to the slaves.

Also how can I get the master to tell me what is happening in the slaves and which clients are connecting to them?

Will one of the more conventional OpenWRT mesh methods work with these routers?


#2

@hansome please send your updated firmware to @Nick for testing.


#3

Hi, Nick, the test firwmare can be downloaded at
http://download.gl-inet.com.s3.amazonaws.com/firmware/testing/qsdk-b1300-2.27.bin
thanks for your feedback.

To check which mesh node client are connecting, you have to use a software to check MAC.

The current mesh methods is based on WiFi SON. Conventional OpenWRT mesh methods work with B1300,
but you have to build firmware from openwrt version greater that 18.06.


#4

Hi, Software for checking MAC addresses, would that be ARP?
And what does that mean? will I see the the slave nodes as wifi clients on the Master?
Am I meant to check the slave nodes to see if there wifi clients are on them? How do I even connect to the Slave nodes?


#5

I tried the new software, but it didn’t seem to make any difference.

The mesh led is light, but that is the only indication it is in a mesh, there is no indication on the master that any slaves have connected to it, which would a line with the clients that prefer to try to get to a barely detectable master rather than work to a slave node that is right next to them.

If it’s in a mesh then the led is the only indication, and the performance is as if the slaves weren’t present.

As for trying to get the backhaul working across a wired network is impossible, it seems that if the router is on a lan it tries to convert to a CAP, the best I could do was end up with 3 master nodes, no router wanted to be a salve.


#6

@Nick, did you upgrade the firmware and reserved the settings? If yes please clear the settings and try again. I think the main problem is the script for mesh.

@hansome, please have a check. Thanks.


#7

Hi,

I took two of the routers and uploaded the new firmware without keeping the existing settings. I then plug the master into the network and got it to pair up with the slave, with nothing connected to the slave.

This seemed to work, and I could see the slave come up as a client on the master.

I then used the GUI to set the wan IP to a static address to 0.0.0.5, this caused the mesh light to go out on the master, but the slave still appeared to be ok.

I then used the GUI to change the SSID and PSK, this was a confusing exercise as the menus seem to be a bit strange, but most have got there as all the clients started to reconnect. At this stage the slave started to slow flash it’s mesh light, which I assume means that it is trying to heal the mesh, I guess the change to SSID isn’t transfered to the slaves…

I then went and did the rest of the changes on the master which include; Change host name, syslog server, bridged all the WAN, LAN and Wifi networks, set a static IP for the LAN interface and disable the DHCP server in the router.

I then tried repairing the slave, but it didn’t want to do this.
I power cycled the slave, and tried repairing it but it still didn’t want to pair.
I reset the slave to factory settings, and then it was able to pair successfully.


#8

Oddly the slave is using the default SSID and PSK, instead of using the one I set on the master.

I can connect to the slave, through the master.

It looks like the master may be a client on the slave as well.

As soon as I try to do any changes in the slave, it drops out and looks like it is trying to heal the mesh again.


#9

Hi,

And finally the wifi network has been odd all evening, the latest is that a wifi client can connect to the network, but as soon as it tries to pass data the wifi connection drops out.

I assume it is being passed to a band that doesn’t exist.


#10

Considering to buy a few units on B1300 to setup a mesh network with mixed wired and wireless backhaul. Can someone provide some information if the mesh networking is working at all on B1300?


#11

I’ve currently got 2 x B1300 using the 2.272 firmware running a mesh network at home. I’ve got wired devices connected to the remote node, including a wired media player and it has been running great.

I actually have a 3rd one that I could setup but found that the 2 provided enough coverage that the 3rd wasn’t necessary.


#12

Thanks for the info. I think I will need 3 or 4 devices, 2 of them will be wired from the master with Cat 6 cables while the other 2 will be connected to the wired ‘salve’ wirelessly. Wonder if it’s possible and how does that affect the throughput of the network?


#13

And also which WiFi mesh does B1300 adapt? OLSR / B.A.T.M.A.N. / 802.11s?


#14

It is Qualcomm WiFi SON technology, which is used by Google, EERO etc as well.

When using cable as backhaul the performance is good. When using WiFi as backhaul the throughout will be affected.


#15

I am having the same problem. I had mesh working with 2 B1300s but when I try to add a third it won’t work.I am adding it by pressing the mesh button on the main router until it flashes at medium speed, then running to do the same on the new router. The lights seem to show that it has worked but the web interface does not show mesh or anything else useful and it won’t let me log int the advanced settings. Otherwise exactly as Nick said, keeps its own SSID and PSK and the whole network seems adversely effected. I have tried resetting the device and repeating but the same result.