B1300 router keeps crashing recently

I have the gl-b1300 for a short while and it worked ok. not the best but it worked. Now suddenly without any changes is the settings of the router it constantly crashes. It still works when it is crashed but very slow and the login page for the router looks like I never set it up yet and asks me for a s/n. if I try to login to the luci interface directly i get an error: 413 - Request Entity Too Large.

Also some of my computers on the network stop working as hostname.lan as if they are not there but connecting by IP works,

here is some output:

root@GL-B1300:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                   15.3M     11.6M      3.6M  76% /
/dev/root                11.3M     11.3M         0 100% /rom
tmpfs                   115.2M    115.2M         0 100% /tmp
/dev/mtdblock10          15.3M     11.6M      3.6M  76% /overlay
overlayfs:/overlay       15.3M     11.6M      3.6M  76% /
tmpfs                   512.0K         0    512.0K   0% /dev
root@GL-B1300:~# free
             total       used       free     shared    buffers     cached
Mem:        236020     233024       2996          0       2856     122820
-/+ buffers/cache:     107348     128672
Swap:            0          0          0

here (openwrt dmesg - Pastebin.com) is the output of dmesg after only a short time after a reboot.

1 Like

Hello, I checked your bootlog, but fail to find a clue. How long is it power up when the memory run out, also have
a check about this command output
du -sh /tmp/
ls -l /tmp/cgisess_*
Many thanks for your feedback.

this happens with an uptime of less than 3 hours.
here is what you asked for:

root@GL-B1300:~# du -sh /tmp/
115.2M	/tmp/
root@GL-B1300:~# ls -l /tmp/cgisess_*

i tried using find there was a very long list… just for an idea of how long I outputted to a file and you can see the size of the file… (my rough calculations tell me aproximately 29000 files)

root@GL-B1300:~# find /tmp/ -name cgisess_* > findoutput.txt

root@GL-B1300:~# ls -al findoutput.txt 
-rw-r--r--    1 root     root       1734305 May 18 12:09 findoutput.txt

now i get an error on

/usr/lib/lua/luci/dispatcher.lua:509: attempt to index local 'f' (a nil value)
stack traceback:
	/usr/lib/lua/luci/dispatcher.lua:509: in function 'createindex'
	/usr/lib/lua/luci/dispatcher.lua:517: in function 'createtree'
	/usr/lib/lua/luci/dispatcher.lua:201: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>

if I do while true; do rm /tmp/cgisess_* && sleep 1;done then things dont lock up but I dont think thats the answer… and of course the (gl.inet not openwrt) website is useless…

can it be some kind of outside attack? I changed the port in /etc/lighttpd/lighttpd.conf and there were not any /tmp/cgisess_* files until I tried to login. When I tried it still asked for s/n so I am not sure if it is fixed yet. and the error in stdout says --HTTP-X-CSRF-TOKEN in /usr/share/glweb/login.html is not transferred

This problem is caused by some antivirus software in your local network, keep sending requests to the router and cause too much useless sessions. What is your antivirus software?

I don’t have any antivirus that is constantly running. All my devices are embedded systems.

This problem has been solved by adding some logic on web ui cgi. Will release a new version about a few days later.