Beryl and App Don’t work


Just got a Beryl and I must be missing something as it’s totally useless…

I can turn it on and get to the config page but when I select the WireGuard VPN Client there are only two options. Ok. According to website I can use the app to add more.

However downloading the app it appears that the only way you can use the app is to reset the router and start from a fresh. A little bit daft, but ok.

I reset the router and the app finds the router but then after setting the router password it take me to a Wi-Fi page that is prepoulated with the Wi-Fi SSID. If I click next it always says “failed”. I tried my local own Wi-Fi network. “Failed”

Therefore, I can’t connect to router through app to set it up for what I brought it for.

What am I missing here?


Ok - I’m a step further on now. I updated the firmware to the latest version, factory reset the device and now I have got my app on my phone connected.

You don’t have to use the app at all and can just upload your VPN configuration using the Web UI of the router. Just add it as another service other than the two that are there by default.

This sounds like a serious bug. Can you tell us the firmware version and the App version. We need to check it

Not totally true. I couldn’t find any files on PIAs website that allowed me to download and then install in router.


Hi - I brought it new from Amazon UK this week. However I didn’t record the firmware before I flashed it.

I tried it multiple times on iPhone and iPad, deleting app and the re-downloading. In this process I factory reset the router 5 times and the app just wouldn’t work.

I was about to send it back to Amazon and it occurred to me that the firmware could be out of date with app. Once flashed to latest stable firmware the app connected fine.

I thought it wise to post my findings in case someone else had the same problem.

I would suggest you change your error phrases to something more meaningful than “failed” so if there is an issue people can report the error to you accurately.