Beryl AX 4.2.0 beta2 - Importing WG configuration files is buggy

I initially added my WG configurations from a zip file and all is good.
Then I changed some parameters in the UI, specifically I had to lower the MTU because I am using a 4g+ connection and Wireguard doesn’t play well with a MTU of 1420.
From this point, If I try to upload more configurations, the UI goes crazy.
For example, trying to upload this file

has this result:

even if I have not touched the MTU field… Seems that is mixing the settings from my existing configurations…
Moreover, yesterday I tried to add configurations to the existing ones from another zip file instead of a single txt file and the WG section in the UI disappeared, leaving a completely blank page on “Dashboard VPN” section. A reboot did not help, I had to reset the firmware…

4.2.0 beta2 has a bug that has duplicated wireguard client peer id.
Fixed in snapshot firmware. Could you have a try?

1 Like

Yeah, just tried and everything seems fine on latest snapshot :wink:

1 Like